Dell EMC Unity:無法使用配置的代理取得技術諮詢 (使用者可修正)

Riepilogo: 取得技術諮詢時發生錯誤

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Sintomi

嘗試從 Unisphere 取得技術諮詢時,產生下列錯誤訊息:

There was an error when retrieving catalog from Dell EMC through configured proxy (Error Code:0x6400bda)'

EMCSystemLogFile.log shows the following:
2021-01-28T17:09:09.974Z" "xxx_spb@APM00123456789" "Neo_CEM" "17037" "local/admin" "WARN" "14:380012" :: "Failed to get technical advisory with configured proxy http://proxy.FQDN.com:8080." :: Category=User Component=EmcSupportServices TimeZone=UTC


The curl command to check connectivity to the Proxy server is failing:

# curl -X POST https://colu.emc.com:443/soap/rpc -H "Content-Type: text/xml;charset=UTF-8" -H "SOAPAction:" -v

Hostname was NOT found in DNS cache
Could not resolve host: colu.emc.com
Closing connection 0
curl: (6) Could not resolve host: colu.emc.com


Adding the proxy server to the curl command succeeds.

# curl -x "http://<proxy.server.url>.com:8080" -X POST https://colu.emc.com:443/soap/rpc -H "Content-Type: text/xml;charset=UTF-8" -H "SOAPAction:" -v
* Hostname was NOT found in DNS cache
* Trying 10.1.1.1...   (proxy server IP)
* Connected to <proxy.server.url>.com (10.1.1.1) port 8080 (#0)
* Establish HTTP proxy tunnel to colu.emc.com:443
> CONNECT colu.emc.com:443 HTTP/1.1
> Host: colu.emc.com:443
> User-Agent: curl/7.37.0
> Proxy-Connection: Keep-Alive


<--snip-->
(see the full output in the Notes)

Causa

在這種情況下,客戶無法直接存取 DNS 伺服器,只能使用代理伺服器退出。  造成此問題的原因是,在 Unity 與代理伺服器之間的資料傳輸完成之前,colu.emc.com 和代理伺服器間的連線便已關閉。  這似乎是由於 curl 處理連線的方式所造成。

Risoluzione

修正
此問題的修正將會包含在未來的 Dell EMC Unity OE 版本中。  請觀看此知識文章以瞭解更新。

因應措施
請勿使用代理伺服器擷取技術諮詢,或設定暫時跳過 Unisphere,直到推出修正此問題的代碼為止。

Informazioni aggiuntive

在將「代理伺服器 URL」新增至 curl 命令時,成功並傳回:

# curl -x "http://<proxy.server.url>.com:8080" -X POST https://colu.emc.com:443/soap/rpc -H "Content-Type: text/xml;charset=UTF-8" -H "SOAPAction:" -v
* Hostname was NOT found in DNS cache
* Trying 10.1.1.1...   (proxy server IP)
* Connected to <proxy.server.url>.com (10.1.1.1) port 8080 (#0)
* Establish HTTP proxy tunnel to colu.emc.com:443
> CONNECT colu.emc.com:443 HTTP/1.1
> Host: colu.emc.com:443
> User-Agent: curl/7.37.0
> Proxy-Connection: Keep-Alive
>
< HTTP/1.1 200 Connection established
<
* Proxy replied OK to CONNECT request
* successfully set certificate verify locations:
* CAfile: none
CApath: /etc/ssl/certs/
* SSLv3, TLS handshake, Client hello (1):
* SSLv3, TLS handshake, Server hello (2):
* SSLv3, TLS handshake, Certificate (11):
* SSLv3, TLS handshake, Server key exchange (12):
* SSLv3, TLS handshake, Server finished (14):
* SSLv3, TLS handshake, Client key exchange (16):
* SSLv3, TLS change cipher, Client hello (1):
* SSLv3, TLS handshake, Finished (20):
* SSLv3, TLS change cipher, Client hello (1):
*SSLv3, TLS handshake, Finished (20):
* SSL connection using TLSv1.2 / ECDHE-RSA-AES256-GCM-SHA384
* Server certificate:
* subject: C=US; ST=Texas; L=Round Rock; O=Dell; CN=colu.emc.com
* start date: 2020-08-25 03:21:00 GMT
* expire date: 2022-08-25 03:21:00 GMT
* subjectAltName: colu.emc.com matched
* issuer: C=US; O=Entrust, Inc.; OU=See www.entrust.net/legal-terms; OU=(c) 2012 Entrust, Inc. - for authorized use only; CN=Entrust Certification Authority - L1K
* SSL certificate verify ok.

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Dell EMC Unity Family
Proprietà dell'articolo
Numero articolo: 000182700
Tipo di articolo: Solution
Ultima modifica: 19 ago 2021
Versione:  3
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