Dell EMC Unity: 구성된 프록시로 기술 권장 사항을 얻는 데 실패(사용자 수정 가능)

Riepilogo: 기술 권장 사항을 수신하는 동안 오류 발생

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Sintomi

Unisphere에서 기술 권장 사항을 검색하려고 하면 다음과 같은 오류 메시지가 생성됩니다.

There was an error when retrieving catalog from Dell EMC through configured proxy (Error Code:0x6400bda)'

EMCSystemLogFile.log에서 다음이 표시됩니다.
2021-01-28T17:09:09.974Z" "xxx_spb@APM00123456789" "Neo_CEM" "17037" "local/admin" "WARN" "14:380012" :: "Failed to get technical advisory with configured proxy http://proxy.FQDN.com:8080." :: Category=User Component=EmcSupportServices TimeZone=UTC


프록시 서버 연결성을 확인하는 curl 명령이 다음과 같이 실패합니다.

# curl -X POST https://colu.emc.com:443/soap/rpc -H "Content-Type: text/xml;charset=UTF-8" -H "SOAPAction:" -v

Hostname was NOT found in DNS cache
Could not resolve host: colu.emc.com
Closing connection 0
curl: (6) Could not resolve host: colu.emc.com


다음의 프록시 서버를 추가하면 curl 명령이 성공합니다.

# curl -x "http://<proxy.server.url>.com:8080" -X POST https://colu.emc.com:443/soap/rpc -H "Content-Type: text/xml;charset=UTF-8" -H "SOAPAction:" -v
* Hostname was NOT found in DNS cache
* Trying 10.1.1.1...   (proxy server IP)
* Connected to <proxy.server.url>.com (10.1.1.1) port 8080 (#0)
* Establish HTTP proxy tunnel to colu.emc.com:443
> CONNECT colu.emc.com:443 HTTP/1.1
> Host: colu.emc.com:443
> User-Agent: curl/7.37.0
> Proxy-Connection: Keep-Alive


<--snip-->
(참고에서 전체 출력 확인)

Causa

이 경우 고객은 DNS 서버에 대한 직접 액세스를 허용하지 않으며 프록시 서버만 사용하여 빠져 나옵니다.  이 문제의 원인은 Unity와 프록시 서버 간의 데이터 전송이 완료되기 전에 colu.emc.com 및 프록시 서버 간의 연결이 닫혔기 때문입니다.  curl이 연결을 처리하는 방식 때문인 것으로 보입니다.

Risoluzione

수정
이 문제에 대한 수정 사항은 향후 Dell EMC Unity OE 릴리스에 포함될 예정입니다.  이 기술 자료 문서에서 업데이트를 확인하십시오.

해결 방법
이 문제를 해결하는 코드가 릴리스될 때까지 프록시 서버를 사용하여 기술 권장 사항을 불러오거나 Unisphere에 대한 임시 바이패스를 설정하지 마십시오.

Informazioni aggiuntive

curl 명령에 '프록시 서버 URL'을 추가하면 성공합니다.

# curl -x "http://<proxy.server.url>.com:8080" -X POST https://colu.emc.com:443/soap/rpc -H "Content-Type: text/xml;charset=UTF-8" -H "SOAPAction:" -v
* Hostname was NOT found in DNS cache
* Trying 10.1.1.1...   (proxy server IP)
* Connected to <proxy.server.url>.com (10.1.1.1) port 8080 (#0)
* Establish HTTP proxy tunnel to colu.emc.com:443
> CONNECT colu.emc.com:443 HTTP/1.1
> Host: colu.emc.com:443
> User-Agent: curl/7.37.0
> Proxy-Connection: Keep-Alive
>
< HTTP/1.1 200 Connection established
<
* Proxy replied OK to CONNECT request
* successfully set certificate verify locations:
* CAfile: none
CApath: /etc/ssl/certs/
* SSLv3, TLS handshake, Client hello (1):
* SSLv3, TLS handshake, Server hello (2):
* SSLv3, TLS handshake, Certificate (11):
* SSLv3, TLS handshake, Server key exchange (12):
* SSLv3, TLS handshake, Server finished (14):
* SSLv3, TLS handshake, Client key exchange (16):
* SSLv3, TLS change cipher, Client hello (1):
* SSLv3, TLS handshake, Finished (20):
* SSLv3, TLS change cipher, Client hello (1):
* SSLv3, TLS handshake, Finished (20):
* SSL connection using TLSv1.2 / ECDHE-RSA-AES256-GCM-SHA384
* Server certificate:
* subject: C=US; ST=Texas; L=Round Rock; O=Dell; CN=colu.emc.com
* start date: 2020-08-25 03:21:00 GMT
* expire date: 2022-08-25 03:21:00 GMT
* subjectAltName: colu.emc.com matched
* issuer: C=US; O=Entrust, Inc.; OU=See www.entrust.net/legal-terms; OU=(c) 2012 Entrust, Inc. - for authorized use only; CN=Entrust Certification Authority - L1K
* SSL certificate verify ok.

Prodotti interessati

Dell EMC Unity Family
Proprietà dell'articolo
Numero articolo: 000182700
Tipo di articolo: Solution
Ultima modifica: 19 ago 2021
Versione:  3
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