Troubleshooting Touchpads and Other Input Devices in Ubuntu on a Dell Computer
概要: The following article provides troubleshooting instructions to identify and resolve an input device issue on a Dell computer running the Ubuntu operating system. (Touchpad, Mouse, Touchscreen, and so on.) ...
現象
Are you experiencing issues with input devices on your Ubuntu Dell Computer?
There are some issues common to various input devices (Touchpad, Mouse, Touchscreen, and so on.). The following sections deal with troubleshooting steps to take in the Ubuntu operating system.
原因
These steps deal with issues such as:
- Device not working or not detected
- Cursor moving or jumping of its own accord
- Device conflicts
- Unable to configure the input devices
解決方法
Troubleshooting steps
Take these steps in order to resolve any input issues:
Most Dell computers now come with a BIOS that uses your input devices to navigate its options:
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Boot the computer into the BIOS, test each input device. Did any device not work in the BIOS?
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If the answer is yes, contact Dell Support if your computer is in warranty to get further help.
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If the answer is no, the issue is with the operating system or the software for the device. Carry on with this guide to further troubleshoot this fault.
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If you have an older BIOS and were not able to isolate the faulty device, follow these instructions:
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Try each input device on its own, to see if you can isolate the faulty device.
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To disable the touchpad:
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Using the Ubuntu Graphical User Interface:
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Go to system and settings
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Go to Mouse and Touchpad
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Click on the on/off slide at the right-hand side of the window to turn the touchpad off or back on
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Using Terminal:
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Identify the device:
xinput -list -
Disable the device:
xinput --disable <device ID>
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To disable the mouse:
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Disconnect the Bluetooth, Wireless, or the USB mouse that you are using from the computer.
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To disable the touch screen:
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Using Terminal:
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Identify the device:
xinput -list -
Disable the device:
xinput --disable <device ID>
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Is you device detected, have you identified all your input devices?
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Type the following command in Terminal:
xinput -list -
It should show a list of input devices on your computer:

(Figure.1 An example of what the list of devices look like)
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Was the device that you were having trouble with listed?
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Yes, carry on to the next section of troubleshooting
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No, it is not listed and there is no other similar device listed.
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No, a different device is shown instead.
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If the answer is NO, you can identify the hardware that shipped with your computer by going to the Dell Support Site:
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Enter your service tag or express service code to get information specific to your computer.
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Go to System Configuration.
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Choose the Original Configuration tab.
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You can go down through the list of components to find out the manufacturer and type of any devices that shipped with your computer.
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In this section, I give some advice on how to accomplish this. This is the last step possible before an Operating system reinstallation is recommended.
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Do you know the manufacturer of the faulty device? (Dell, Synaptics, Alps, and so on.)
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If you know the manufacturer and type of device, you can reach out to the Ubuntu community to see if someone has or can create software for you to get the device running:
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If you are seeing conflicts or software for more than one device, follow the instructions in the following article:
The last resort is to recover the system image or to reinstall the operating system from install media.
Ubuntu Came Installed on your computer
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Follow the instructions on the following article:
You are looking to install Ubuntu on a computer that came with a Windows operating system
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Follow the instructions on the following article:
Your issue continues after reinstalling the Operating System
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Contact us for further help: