PowerStore:言語パックのインストール後にGUIで言語設定を変更できない
概要: 言語パックのインストール後、PowerStore Manager GUIで言語設定の変更に失敗します。
この記事は次に適用されます:
この記事は次には適用されません:
この記事は、特定の製品に関連付けられていません。
すべての製品パージョンがこの記事に記載されているわけではありません。
現象
言語パックをインストールした後、ユーザーは言語を優先言語に変更しようとします(例: ポルトガル語(ブラジル)をGUIで実行すると、GUIに次のエラーが表示され、言語は変更されません。
この問題は、他の言語にも影響します。
原因
PowerStore Managerは常にブラウザーの優先言語を検出し、そのロケールを使用して、translation.jsonと branding.json ファイルをロードします。Language Packがインストールされていない場合、PowerStore Managerはそのロケールの translation.json および branding.json にアクセスしようとします。結果は予想どおりHTTP 404になり、結果はCPサーバーにキャッシュされます。この問題は、言語パックのインストール後にCPキャッシュがクリアされない場合に発生します。その結果、言語パックをインストールした後、ユーザーが言語をブラウザの希望する言語に変更しようとすると、GUIはそのロケールで translation.json および branding.json をロードしても HTTP 404 を取得し、GUI が言語を変更するのを防ぎます。
解決方法
この問題が発生した場合は、「svc_container_mgmt」サービス スクリプトを使用してサービス コンテナでCPを再起動します。
svc_container_mgmt restart CP
言語を希望の言語に変更するときにCPを再起動した後も問題が引き続き発生する場合は、お客様のブラウザでキャッシュとCookieをクリアします。
その他の情報
svc_container_mgmtの実行の詳細については、『 Dell EMC PowerStoreサービス スクリプト ガイド 』を参照してください。
対象製品
PowerStore文書のプロパティ
文書番号: 000202758
文書の種類: Solution
最終更新: 13 6月 2025
バージョン: 6
質問に対する他のDellユーザーからの回答を見つける
サポート サービス
お使いのデバイスがサポート サービスの対象かどうかを確認してください。