PowerStore: Spracheinstellungen in der GUI können nach der Installation des Sprachpakets nicht geändert werden
概要: Der Benutzer kann die Spracheinstellung in der PowerStore Manager-GUI nicht ändern, nachdem ein Sprachpaket installiert wurde.
この記事は次に適用されます:
この記事は次には適用されません:
この記事は、特定の製品に関連付けられていません。
すべての製品パージョンがこの記事に記載されているわけではありません。
現象
Nachdem das Sprachpaket installiert wurde, versucht der Benutzer, die Sprache in die bevorzugte Sprache zu ändern (z. B.: Portugiesisch (Brasilien) in gui und GUI zeigt die folgenden Fehler an und die Sprache wird nicht geändert:
Dieses Problem betrifft auch andere Sprachen.
原因
PowerStore Manager erkennt immer die bevorzugte Sprache des Browsers und verwendet dieses Gebietsschema, um die Dateien translation.json und branding.json zu laden. Wenn kein Sprachpaket installiert ist, versucht PowerStore Manager, für dieses Gebietsschema auf translation.json und branding.json zuzugreifen. Das Ergebnis ist HTTP 404 wie erwartet und das Ergebnis wird im CP-Server zwischengespeichert. Das Problem tritt auf, wenn der CP-Cache nach der Installation des Sprachpakets nicht gelöscht wird. Wenn der Benutzer daher nach der Installation des Sprachpakets versucht, die Sprache in die bevorzugte Sprache des Browsers zu ändern, erhält die GUI beim Laden von translation.json und branding.json in diesem Gebietsschema immer noch HTTP 404, was verhindert, dass die GUI die Sprache ändert.
解決方法
Wenn dieses Problem auftritt, starten Sie CP in einem Servicecontainer mithilfe des Serviceskripts "svc_container_mgmt".
svc_container_mgmt restart CP
Wenn das Problem weiterhin auftritt, nachdem CP neu gestartet wurde, wenn die Sprache in die bevorzugte Sprache geändert wird, löschen Sie den Cache und die Cookies im Browser des Kunden.
その他の情報
Weitere Informationen zur Ausführung von svc_container_mgmt finden Sie im Dell EMC PowerStore Service Scripts Guide (Dell EMC PowerStore-Serviceskripthandbuch).
対象製品
PowerStore文書のプロパティ
文書番号: 000202758
文書の種類: Solution
最終更新: 13 6月 2025
バージョン: 6
質問に対する他のDellユーザーからの回答を見つける
サポート サービス
お使いのデバイスがサポート サービスの対象かどうかを確認してください。