NVE: Upgrade Failed invalid byte sequence in UTF-8

概要: NetWorker Virtual Edition (NVE) upgrade failed, reporting "Default Server Protection Policy is corrupt or does not exist. Please validate the Server Protection before proceeding with the upgrade. - operation failed" ...

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現象

While upgrading the NetWorker Virtual Edition (NVE) appliance, The upgrade fails. The following error is found in the NVE's /data01/avamar/repo/temp/*/tmp/workflow.log:

2023-01-09 15:04:05 (+0100) 47081677224620 INFO: ---------- BEGIN ValidateServerProtectionPolicy::do ----------
2023-01-09 15:04:05 (+0100) 47081677224620 INFO: >>> [make_temp_script] 222 very_current_user=root, as_user=root, ssh command is: (nsradmin -s 127.0.0.1 -i /space/avamar/repo/temp/NveUpgrade-19.8.0-23.avp_1673272933099/tmp/nsr-config.txt) >/usr/local/avamar/var/run_command-sysout.28416.47081677224620 2>&1
2023-01-09 15:04:05 (+0100) 47081677224620 ERROR: ERROR: invalid byte sequence in UTF-8
2023-01-09 15:04:05 (+0100) 47081677224620 DETAILS: ERROR: invalid byte sequence in UTF-8

原因

There was a non-UTF-8 character "Â" at Notifications field from Server Protection Policy:

mail -h smtp.domain.com -s 'Networker Bootstrap Recovery Clone failed' backupadmin@email.com

It seems that the command was copied and pasted from another place and it came with a non-UTF-8 character in it.

This field does not support non-UTF-8 characters, and that was the reason for the failure.

解決方法

  1. Open the NetWorker Management Console (NMC).
  2. Go to the Server Protection policy under the Protection tab.
  3. Right click at the Server Protection Policy.
  4. Delete and manually reenter the notification command from the notification field to avoid any nonsupported character, click OK button.
  5. Go back to the Installation Manager and click retry button.

その他の情報

対象製品

NetWorker Family, NetWorker

製品

NetWorker Series
文書のプロパティ
文書番号: 000208045
文書の種類: Solution
最終更新: 13 1月 2026
バージョン:  2
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