Avamar DB2 backup fails with "security error" due to DB2 instance user or password having changed or expired
概要: Avamar DB2 backup fails, avdb2 log shows "security error."
この記事は次に適用されます:
この記事は次には適用されません:
この記事は、特定の製品に関連付けられていません。
すべての製品パージョンがこの記事に記載されているわけではありません。
現象
Avamar DB2 backup fails and generates the following errors in the backup log.
db2diag.log shows that db2agent tries to log in with the db2admin account. The task fails due to an incorrect password:
The avdb2 log show which db2 instance user is configured:
2023-03-02 07:46:10 avdb2 Error <9004>: DB2 returned security error -30082
2023-03-02 07:46:10 avdb2 Info <9772>: Starting graceful (staged) termination, Unable to attach to the instance. (wrap-up stage)
2023-03-02 07:46:10 avdb2 Error <19177>: Snapup of db2portl/FDBKDB Terminated.
2023-03-02 07:46:47 avdb2 Info <6688>: Process 9437492 (/usr/local/avamar/bin/avtar) finished (code 0: success)
2023-03-02 07:46:47 avdb2 Error <16729>: Unable to get the list of backup images from the child process.
2023-03-02 07:46:47 avdb2 Info <9772>: Starting graceful (staged) termination, Unable to get the list of backup images from the child process. (wrap-up stage)
2023-03-02 07:46:47 avdb2 Error <43351>: Failed to create the snapview. However, the database data has been successfully backed up and is marked as a hidden backup. Restore is available through CLI only. See the plug-in documentation for information about restoring hidden backups.
db2diag.log shows that db2agent tries to log in with the db2admin account. The task fails due to an incorrect password:
2023-03-05-23.00.11.998228-300 I8253775A506 LEVEL: Warning
PID : 12911084 TID : 68893 PROC : db2sysc 0
INSTANCE: db2inst1 NODE : 000
APPHDL : 0-42482 APPID: *LOCAL.db2portl.230306040019
HOSTNAME: db2_host_name
EDUID : 68893 EDUNAME: db2agent (instance) 0
FUNCTION: DB2 UDB, bsu security, sqlexLogPluginMessage, probe:20
DATA #1 : String with size, 67 bytes
Password validation for user db2admin failed with rc = -2146500507
The avdb2 log show which db2 instance user is configured:
<flag type="string" pidnum="5009" value="db2admin" name="db2_inst_user" />
<flag type="string" pidnum="5009" value="db2inst1" name="db2_inst_name" />
原因
The DB2 instance user or password has changed or expired.
解決方法
Provide the error from db2diag.log to the customer database administrator so that they can confirm the status of the user account. It may be different to db2admin.
After confirming valid credentials, update these fields in the DB2 dataset:
After confirming valid credentials, update these fields in the DB2 dataset:
- Instance Admin Username
- Instance Admin Password
その他の情報
Log in to Dell support to view this article with steps for collecting logs / db2diag.log
Avamar DB2 plugin: Logs required to troubleshoot backup or restore failures.
Avamar DB2 plugin: Logs required to troubleshoot backup or restore failures.
対象製品
Avamar Plug-in for IBM DB2文書のプロパティ
文書番号: 000211371
文書の種類: Solution
最終更新: 02 6月 2023
バージョン: 2
質問に対する他のDellユーザーからの回答を見つける
サポート サービス
お使いのデバイスがサポート サービスの対象かどうかを確認してください。