VxRail: vCenter VAMIエラー: 導入ステータスを取得できませんエラー
概要: vCenterアプライアンス管理インターフェイス(VAMI)が導入ステータスを取得できません。これは、ドメイン ネーム システム (DNS) の障害、ファイルのアクセス許可、fbInstall.jsonの破損、または 0 バイト マーカー ファイルの欠落が原因である可能性があります。
この記事は次に適用されます:
この記事は次には適用されません:
この記事は、特定の製品に関連付けられていません。
すべての製品パージョンがこの記事に記載されているわけではありません。
現象
VAMIおよびvCenterへのアクセス時に観察される問題
VAMIアクセス エラー
- VAMIを開こうとすると、エラー メッセージが表示される
"Unable to get deployment status.”
Unable to get deployment status
vCenterの起動および構成インジケータ。
- という名前のファイル
failedに表示されます/var/log/firstboot/. - の内容は、
failedファイルを示す"Failed to configure network.” - vCenterがDNSサーバーにpingを実行できません。
アプリケーション管理ログ
- ログ
/var/log/vmware/applmgmt/applmgmt.logエントリ「INSTALL_IN_PROGRESS"
... INSTALL_IN_PROGRESS ...
fbInstall.json ファイルの異常
- ファイル
fbInstall.jsonに存在する場所/var/log/firstboot/しかし、不正な権限を持っている可能性があります(644)を使用するシステムで一般的に行われる、繰り返しのプログラムおよび消去サイクルによって劣化しやすい傾向があります。 - JSONコンテンツに、
100または「成功」以外の「ステータス」値。
{
"progress": 85,
"status": "in_progress"
}
ディレクトリー ファイルのアップグレード
- インチ
/var/log/vmware/upgrade/,予期されるファイルPrechecks-succeeded、Exports-succeededとImport-succeeded欠落しているか、サイズが 0 キロバイトではありません。
原因
VAMIの「導入ステータスを取得できません」につながる根本的な要因
- DNS解決の失敗 vCenter ServerがDNSサーバーをpingまたは解決できない場合、VAMIは必要なサービスに到達できません。
- 初回起動時のネットワーク構成エラー。インチ
/var/log/firstboot/failedの場合、ファイルには"Failed to configure network.” - での不適切なファイル権限
/var/log/firstboot/fbInstall.json644(RW-R--R--)以外は、インストール プロセスが進行状況とステータス情報を読み取れないようにします。 - インストールが進行中とログに表示されます。における 「INSTALL_IN_PROGRESS」 の存在
/var/log/vmware/applmgmt/applmgmt.logは、導入が完了していないことを示しています。 - 破損または不完全
fbInstall.json「progress」(100ではない)または「status」(「success」ではない)フィールドが見つからないか形式が正しくない場合、VAMIは未定義の導入状態を報告します。 - に 0 バイトマーカーファイルがありません
/var/log/vmware/upgrade/の不在Prechecks-succeeded,Exports-succeededまたはImport-succeeded動作条件のステップが完了として記録されなかったことを示します。
解決方法
VAMIにアクセスし、DNS構成を確認します。
初回アクセス チェック
直接IPアドレスを使用してVAMIインターフェイスを開いてみます。
https://:5480/configurev2
エラーが "Unable to get deployment statusが表示されたら、次の手順に進みます。
DNS検証
- vCenterホストがDNSサーバーを解決し、pingを実行できることを確認します。
- ブラウザーのキャッシュをクリアするか、別のブラウザーを試してください。
- 詳細については、VxRailの記事 「VxRail:vCenterで導入ステータスを取得できない (英語)」を参照してください。
注意: DNS設定が正しくないと、以降の導入手順が妨げられる可能性があります。続行する前に、接続を確認してください。
初回起動ログにネットワーク エラーがないか調べます。
障害ファイルを見つけます。
# List files in the firstboot log directory ls -l /var/log/firstboot/ # If a file named "failed" exists, display its contents cat /var/log/firstboot/failed
ファイルに "Failed to configure network,” vCenterがDNSサーバーにpingを実行し、ネットワーク構成の誤りを修正できることを確認します。
アプリケーション管理のステータスを確認します。
進行中のインストールを検索します。
# Look for the INSTALL_IN_PROGRESS flag grep -i "INSTALL_IN_PROGRESS" /var/log/vmware/applmgmt/applmgmt.log
検証 fbInstall.json
# Verify the file exists ls -l /var/log/firstboot/fbInstall.json # Confirm permissions are 644 (rw-r--r--) ls -ltrh /var/log/firstboot/fbInstall.json # Review the JSON content cat /var/log/firstboot/fbInstall.json
JSON出力で、次のことを確認します。
"progress"が100"status"が"success"
必要に応じて、applmgmtサービスを再起動します。
# Stop the service service-control --stop applmgmt # Edit the JSON file (use vi or your preferred editor) to correct any incorrect values vi /var/log/firstboot/fbInstall.json # Start the service service-control --start applmgmt
注: JSONファイルの編集は注意して行う必要があります。変更を加える前に、必ず元のファイルをバックアップしてください。
アップグレード完了ファイルを確認します。
0バイトの成功マーカーを確認します。
cd /var/log/vmware/upgrade/ ls -lh
想定されるファイル(各0 KB):
Prechecks-succeededExports-succeededImport-succeeded
欠落しているマーカーを作成します。
# Add the files using the touch command. Replace <FILE_NAME> with one of the files above, e.g., Prechecks-succeeded Example: touch Prechecks-succeeded # Restart the lightweight VAMI web server Prior to 8.0U3: /sbin/service vami-lighttp restart 8.0U3 and above: systemctl restart cap-lighttpd.service
注意: Restarting」
vami-lighttp VAMIアクセスを一時的に中断します。可能な場合は、メンテナンス期間中にこのステップを実行します。
最終検証
- VAMIへのアクセス方法
https:// :5480/configurev2導入ステータスがエラーなしでロードされていることを確認します。 - 次のコマンドを実行して、インストールが進行中でないことを確認します。
grep -i "INSTALL_IN_PROGRESS" /var/log/vmware/applmgmt/applmgmt.log || echo "No active installation"
- 3つの成功マーカー ファイルが存在し、0 KBのままであることを確認します。
- vCenterホストからDNSサーバーへのネットワーク接続を確認します。
注: すべての手順を完了しても問題が解決しない場合は、Broadcomの記事「VAMIにアクセスすると「導入ステータスを取得できません」というエラーが返される」
またはDellサポート ケースを開いてください。
対象製品
VxRail, VxRail Appliance Series, VxRail Software文書のプロパティ
文書番号: 000382558
文書の種類: Solution
最終更新: 22 12月 2025
バージョン: 2
質問に対する他のDellユーザーからの回答を見つける
サポート サービス
お使いのデバイスがサポート サービスの対象かどうかを確認してください。