NetWorker: REST API log folder is missing
Podsumowanie: This KB provides instructions on how to reconfigure REST API logging if the restapi logs directory does not exist.
Objawy
The NetWorker server's REST Application Programming Interface (API) logs directory is missing:
- Linux:
/nsr/logs/restapi - Windows:
C:\Program Files\EMC NetWorker\nsr\logs\restapi
Restarting services does not re-create the REST API log directory.
Przyczyna
The REST API logs folder was renamed or deleted, either accidentally by a user or as part of a troubleshooting attempt.
Rozwiązanie
On Windows servers, re-creating the C:\Program Files\EMC NetWorker\nsr\logs\restapi directory should resolve the issue. Once the folder is created, the restapi.log should appear; however, a NetWorker service restart may be required. This path assumes the default NetWorker installation path is used. If another drive or installation path is used, the 'restapi' folder should be created under the ..\nsr\logs location.
On Linux servers, you must perform the following:
pcs) cluster.
1. Re-create the REST API logs folder:
sudo mkdir /nsr/logs/restapi
2. Set permissions on the folder:
sudo chmod 755 /nsr/logs/restapi
3. Change ownership of the folder to nsrtomcat:
sudo chown -R nsrtomcat:nsrtomcat /nsr/logs/restapi
systemctl restart networker
5. The REST API log should be re-created and show a nwrestapi service startup.

Dodatkowe informacje
If the NetWorker server is a Linux pacemaker (pcs) cluster, see: NetWorker: restapi.log file not generated on NetWorker server deployed on Red Hat pacemaker cluster.
NetWorker: How to Enable REST API Debugging