Dell Encryption protected devices fail to boot with Operating System Loader failed signature verification
摘要: Devices fail to boot with Operating System Loader failed signature verification when protected by Dell Data Protection | Encryption.
症狀
Affected Products:
- Dell Encryption
- Dell Data Protection | Encryption
Affected Platforms:
- Windows 8.1
- Windows 10RTM
- Windows 10 1511
原因
Microsoft has released an update (MS16-100 aka KB3172729) for Windows 8.1, Windows 10 RTM, and Windows 10 1511; This update has an update for SecurBook that may cause the EFI boot partition to be mounted as a nonsystem disk, causing Dell Encryption (formerly Dell Data Protection | Encryption) to encrypt the files on that partition. This leads to an error stating that the Operating System Loader Signature is invalid:

Figure 1: (English Only) Operating System Loader Signature is invalid
解析度
How can I prevent this?
This can be mitigated completely by adding an exclusion to an EFI folder to Fixed Disk and General setting policies.
-^3F#:\EFI\
This policy when added to the current encryption policies prevent this from occurring. It is suggested to add this to both policies to prevent Common and SDE from affecting these files.
How can I remediate a device in this state?
- Launch the install media. At the Windows Setup screen, click the Next button in the bottom-right corner of the window.

Figure 2: (English Only) Windows Setup screen
- Click the Repair your computer link in the bottom-left corner of the window.

Figure 3: (English Only) Repair your computer
- Click Troubleshoot.

Figure 4: (English Only) Troubleshoot
- Click Advanced options.

Figure 5: (English Only) Advanced Options
- Click Startup Repair.

Figure 6: (English Only) Startup Repair
- If prompted to select the target operating system, click Windows 8.1.

Figure 7: (English Only) Select Windows 8.1
- Allow the startup repair to complete.
- Reboot
- Launch the install media. At the Windows Setup screen, click the Next button in the bottom-right corner of the window.

Figure 8: (English Only) Windows Setup screen
- Click the Repair your computer link in the bottom-left corner of the window.

Figure 9: (English Only) Repair your computer
- Click Troubleshoot.

Figure 10: (English Only) Troubleshoot
- Click Advanced options.

Figure 11: (English Only) Advanced Options
- Click Startup Repair.

Figure 12: (English Only) Startup Repair
- If prompted to select the target operating system, click Windows 10.

Figure 13: (English Only) Windows 10 selection
- Allow the startup repair to complete.
- Reboot
To contact support, reference Dell Data Security International Support Phone Numbers.
Go to TechDirect to generate a technical support request online.
For additional insights and resources, join the Dell Security Community Forum.