PowerProtect Data Manager: SQL Agent discoveries do not show any assets under Assets/SQL DATABASES

Summary: This Article addresses an issue where SQL Databases do not show up after running a discovery.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Assets > SQL DATABASES do not show any SQL Databases after discover is run manually several times.

In SQL Server, the ADM log shows (ADM log: C:\Program Files\DPSAPPS\MSAPPAGENT\ADM Agent\logs):

...
(

Disposition: form-data; name="results"; filename="C:\\Windows\\TEMP\\ecdmruncmd775979743"
Content-Type: application/octet-stream

{
    "response": {
        "APIVersion": "2.2",
        "applicationInstances": []
    },
    "errors": [
        {
            "type": "systemErr",
            "text": "General exception when detecting AAG information for SQL Server '<SQL SERVER name>'.\n"
        }
    ]
}

 

Cause

PowerProtect Database Manager Console fails to connect to the SQL server using the LocalSystem Account.

 

Resolution

Procedure:

  1. On the Windows SQL Server, go to services.msc.
  2. Select ADM agent.
  3. Right click and select Properties.
  4. Click Log On.
  5. Click This account and input a Windows user with access to the SQL server.
    Note: Sometimes, the software works better if the Windows user is a Domain Admin as well. If possible, ensure that the Windows user has access to SQL Server and is a Domain Admin as well.
  6. Restart the service.

 

Affected Products

PowerProtect Data Manager

Products

PowerProtect Data Manager, PowerProtect X400 Appliance
Article Properties
Article Number: 000042143
Article Type: Solution
Last Modified: 25 Nov 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.