Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products
  • Manage your Dell EMC sites, products, and product-level contacts using Company Administration.

No POST 2-7 after BIOS Update on Dell G15 5515 and Alienware m15 R5 Ryzen Edition Laptops

Summary: The following article provides information about a No POST error on Dell G15 5515 and Alienware m15 R5 Ryzen Edition laptops. The flash error code two and seven that is repeated and reported after the BIOS has been updated. ...

This article may have been automatically translated. If you have any feedback regarding its quality, please let us know using the form at the bottom of this page.

Article Content


Symptoms

No POST error after updating the BIOS

 

Owners of Dell G15 5515 and Alienware m15 R5 Ryzen Edition gaming laptops may experience a start-up error after updating the BIOS. On restart the computer fails the Power-On Self-Test (POST) with a repeated LED flash code of two amber/red LEDs and then seven white/blue LEDs.

  • Error Flash LED code: two Amber and seven White repeated, represents an LCD failure on a G-Series product
  • Error Flash LED code: two Red and seven Blue repeated, represents an LCD failure on an Alienware product

The BIOS versions known to show this fault are:

  • v1.11.1 - Dell G15 5515 Ryzen Edition Gaming Laptop
  • v1.12.1 - Alienware m15 Ryzen Edition R5 Gaming Laptop


Back to Top

Cause

This section is not applicable to this article.

Resolution

Dell has removed the affected BIOS versions from our support site.

You can run through the following steps to resolve this problem:

Note: Your user account must have administrator privileges when working on your laptops operating system. (Such as using Device Manager or rolling back the BIOS.)
 
  1. You must start by recovering the laptop from the No POST error. Pick one of the following methods:

    • Recover the laptop by resetting the Real Time Clock (RTC):

      1. Remove the AC adapter and turn off the laptop.

      2. Connect the AC adapter to the laptop.

      3. Press and hold the power button until the power LED blinks three times. (For at least 30 to 35 seconds.)

      4. Release the power button.

      5. The RTC reset is complete after the power button is released.

      6. See the following Dell Knowledge Base article for more information about the subject:

    • Recover the default BIOS using the BIOS recovery screen:

      1. Unplug the AC adapter.

      2. Press the CTRL + ESC keys together and release simultaneously.

      3. Plug the AC adapter into the wall socket and into the laptop.

      4. The laptop displays the BIOS recovery menu on-screen.

      5. Select Reset BIOS settings to Default from the recovery page list.

        (Use the Arrow or Cursor keys to navigate the menu.)

        BIOS Recovery List

        (Figure.1 BIOS Recovery Page Option)

      6. The laptop reboots and on rebooting, it boots into the Windows operating system without any error messaging.

  2. Identify and remove the Windows update firmware if it exists in Device Manager:

    1. Click on the Start Menu and type Device Manager into the search bar and press the Enter key.

    2. Select open from the menu that appears under the utility in the search returns.

    3. Look down the list for Firmware in the windows that opens on the desktop:

      1. If you find Firmware, click on it to open up a tree section with further entries.

      2. If you can see the entry System Firmware 01.11.01 or System Firmware 01.12.01, right-click the entry to open a menu.

        Example: System Firmware 01.11.01

        (Figure.2 Example: System Firmware 01.11.01)

      3. If you can see the entry System Firmware 01.11.01 or System Firmware 01.12.01, right-click the entry to open a menu.

      4. Click on Uninstall Device on the menu that appears. Click uninstall on the uninstall device windows that appears.

        Uninstall the device

        (Figure.3 Uninstall the device)

    4. If you do not see either System Firmware 01.11.01 or System Firmware 01.12.01, go on to Step.3.

Warning: Dell Technologies recommends disconnecting devices such as external hard drives, printers, scanners, and so on before rolling back or updating the BIOS.
 
Warning: Dell laptops must have the battery installed and charged to at least 10% before you begin to roll back the BIOS. Dell Technologies recommends connecting the laptop to AC power before proceeding with this process.
 
Note: To learn more about the BIOS on a Dell computer, see the following Dell knowledge base article: Dell BIOS Updates
 
  1. Manually roll back the BIOS to the version available in the Dell support site for your laptop:

    1. Browse to your laptops Drivers & Downloads page:

    2. Select the Operating System that is installed on your laptop.

    3. Under Category, select BIOS.

    4. Locate:

      • The Dell G15 5515 System BIOS (Version 1.9.0)

      • The Alienware m15 R5 System BIOS (Version 1.9.0)

    5. Click Download and save the file to your computer.

    6. Open File Explorer and browse to the download folder where the downloaded file is saved.

    7. Double-click the BIOS setup file and follow the on-screen instructions to complete the installation process.

    8. The computer reboots as part of the rollback installation and boots back into the operating system.


Back to Top

Article Properties


Affected Product

Alienware m15 Ryzen Edition R5, Dell G15 5515 Ryzen Edition

Last Published Date

19 Jun 2023

Version

3

Article Type

Solution