PowerProtect: NAS Backup fails when timeout expires
Summary: For large file systems containing only empty folders, jobs may be terminated prematurely.
Symptoms
The nasdm.log contains these types of errors:
ALERT:ABN0004
It seems job is at hung state for a while, so cancelling the job.
Cause
PowerProtect Data Manager's unresponsive-job timer depends on files being found on the file system to reset the unresponsive-job timer.
If a file system contains only directories and it takes longer than the configured timeout period to traverse the empty directories, the workflow service cancels the job.
Resolution
Use a file filter to skip the empty folders.
Delete empty folders.
Extend asset timeout up to 12 hours maximum.
Grep the 'BackupSnapshot*log for: updateTimeOut to get the effective timeout value.
The default is 10,800 seconds (3 hours) and can be extended to a maximum of 12 hours.
Set the unresponsive job timeout in the UI from the asset's 'More Actions' menu under 'Assign Configurations'.