Dell Automation Platform: Resolving 504 Gateway Errors on Deployments and Blueprints Pages

Summary: This article describes a rare issue where the Deployments and Blueprints pages fail to load, resulting in a 504 Gateway Time-out error. The error is potentially related to the nginx server. A workaround is provided to resolve the issue. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • The Deployments and Blueprints pages cannot be loaded.
  • A 504 Gateway Time-out error is displayed.
  • The error message goes from nginx/1.25.4.

Error Message: The error message is an HTML page with the following content:

<html> <head><title>504 Gateway Time-out</title></head> <body> <center><h1>504 Gateway Time-out</h1></center> <hr><center>nginx/1.25.4</center> </body> </html> <!- a padding to disable MSIE and Chrome friendly error page -> <!- a padding to disable MSIE and Chrome friendly error
page -> <!- a padding to disable MSIE and Chrome friendly error page -> <!- a padding to disable MSIE and Chrome friendly error page -> <!- a padding to disable MSIE and Chrome friendly error page -> <!- a padding to disable MSIE and Chrome friendly error page ->

Cause

The root cause of the issue is unknown at this moment, but it is suspected to be related to the nginx server.

Resolution

Workaround: Restart the nginx server to resolve the issue. This should allow the Deployments and Blueprints pages to load correctly.

To restart the nginx pod, follow these steps on the Dell Automation Platform cluster:

Identify the name of the fusion-nginx pod by running the command. This displays the pod name, similar to the example output:

# kubectl get pods -A | grep fusion-nginx
hzp                fusion-nginx-758ddd5f7c-g6dfj                       2/2     Running            2 (66d ago)       93d

Delete the pod using the command below. Replacing <pod_name> with the name of the pod (for example, fusion-nginx-758ddd5f7c-g6dfj) and <namespace> with the correct Orchestrator namespace (for example, hzp

# kubectl delete pod fusion-nginx-758ddd5f7c-g6dfj -n hzp
pod "fusion-nginx-758ddd5f7c-g6dfj" deleted

The Kubernetes scheduler will automatically restart the nginx pod immediately after deletion. You can verify the pod's deletion and restart by checking the output of the delete command. This should display a message indicating that the pod has been deleted.

 

Fix: This issue is under investigation by Dell Automation Platform development.

Affected Products

Dell Automation Platform, NativeEdge Solutions, Dell Automation Platform Components, NativeEdge
Article Properties
Article Number: 000391508
Article Type: Solution
Last Modified: 14 Nov 2025
Version:  1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.