CloudLink: Агент Cloudlink перестає відповідати через витік пам'яті.

Summary: Агент CloudLink аварійно завершує роботу через витік пам'яті, виявлений у версіях 7.1.1 та 7.1.2. Клієнтів KMIP це не стосується.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Агент відключиться від CLC через витік пам'яті. Під час цього адміністративні операції, такі як додавання нових дисків, видалення дисків, заміна ключів, не можуть бути виконані, оскільки агент не працює. Це не вплине на операції вводу-виводу, оскільки на дисках вже є ключі.

Журнали ОС:
Linux:
Після збою служби svmd на Linux запис у /var/log можна побачити на RHEL або CentOS, що показує помилку з пам'яті.зображення.png
Вікна:
У випадку Windows будь-яке аварійне завершення роботи реєструватиметься в журналах перегляду подій Windows. Оскільки служба може автоматично запускатися в Windows із налаштуваннями відновлення за замовчуванням, агент спробує повторно підключитися до сервера CloudLink.
 
У веб-інтерфейсі Cloudlink Center агент показує відключення після збою служби:
зображення.png

Багатосесійні журнали показують, що сеанс агента закривається після збою служби:
зображення.png

Cause

CloudLink оновив бібліотеку TLS 3-ї сторони, яка використовується в агенті, до останньої версії для відповідності безпеці. Новіша версія бібліотеки має модифікований потік обміну повідомленнями, що призводить до розподілу пам'яті в коді агента в циклі.

Resolution

Резолюція:
Для повторного запуску служби потрібен перезапуск служби агента CloudLink.
  • У Linux: Службу агента можна перезапустити вручну після збою. Втрат даних немає, оскільки зашифрований диск залишається зашифрованим. Командою для перезапуску служби агента є service svmd restart.
  • У Windows: Після збою Windows автоматично перезапустить службу, якщо в параметрах відновлення служби встановлено перезапуск служби (за замовчуванням). Втрат даних немає, оскільки зашифрований диск залишається зашифрованим.

Постійне виправлення:
Цю проблему вирішено в CloudLink 7.1.3.

Additional Information

ОС Linux:
Наприклад, у системі з 2 ГБ пам'яті служба агента виходить з ладу через 5 днів, коли споживання пам'яті зростає майже на 1.6 ГБ із середнім витоком 300 МБ на день.

ОС Windows:
Наприклад, у системі з 4 ГБ пам'яті споживання пам'яті служби агента зростає і досягає розміру близько 1.9 ГБ. Очікується, що він вийде з ладу, коли досягне близько 3 ГБ із витоком в середньому 400 МБ на день.

Affected Products

CloudLink SecureVM, CloudLink
Article Properties
Article Number: 000197219
Article Type: Solution
Last Modified: 13 مايو 2026
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.