Passerelle de connexion sécurisée : L’échec du chargement des collectes s’affiche sur l’interface utilisateur du plug-in SCG et OME Services
Zusammenfassung: Depuis février 2024, dans les anciennes versions de Secure Connect Gateway et d’OpenManage Enterprise (OME) Services Plugin, l’état des collectes sur l’interface utilisateur affiche État du téléchargement = Échec. Étant donné que les charges utiles de collecte sont téléchargées sur les systèmes back-end, mais que la réponse à la passerelle entraîne l’affichage de l’échec par l’interface utilisateur. Il est possible d’ignorer ce message d’échec de l’interface utilisateur. ...
Symptome

Versions concernées :
SCG - v5.16 et versions inférieures
Plug-in OME Services - v3.0.x et versions inférieures.
Enquête initiale :
- Vérifiez la version de l’application.
- Contactez le support technique Dell en envoyant un ticket pour vérifier si les collectes ont bien été téléchargées et si elles sont disponibles pour consultation par les agents Dell.
Consulter les journaux :
Vous voyez des échecs dans les journaux, comme indiqué ci-dessous :
ERROR com.dell.scg.gateway.handler.response.ResponseHandler- 172 - Error in Backend communication
io.vertx.serviceproxy.ServiceException: {"errorCode":"","errorMessage":"{\"status\": 500, \"requestId\": \"xxxc298a4daxxxxx4d899c0xxxxxx\", \"message\": \"Request processing failed: org.springframework.web.client.ResourceAccessException: I/O error on GET request for \https://is.us.dell.com/FRS/api/v1/File/SAE-OME_FILE_xxxxxx-8fcd-xxxx-8232-a8667xxxxxxx_20240222T1117XXXXX.zip/fileStatus\: Connection reset\"}","httpStatus":500,"errorReason":"Internal Server Error"}
Ursache
Ce problème est spécifique à SCG 5.16 et aux versions antérieures , ainsi qu’au plug-in OME Services 3.0.x et aux versions antérieures . Il provient d’un échec d’appel d’API, entraînant un affichage incorrect de l’état du téléchargement de fichiers sur l’interface utilisateur.
Lösung
Pour SCG, effectuez une mise à niveau vers la dernière version
. Pour le plug-in OME Services, migrez vers la dernière version d’OpenManage Enterprise et d’OpenManage Enterprise Services Plugin.
Le problème ne se produit pas dans la dernière version de l’un ou l’autre des produits.