Avamar: INTERNAL CYCLE ERROR로 복제 실패

Summary: avtar 오류와 함께 Avamar 복제 실패 <5445>: 내부 주기 오류: repldata DST_ADD_DATA의 잘못된 응답: ADD_HASH_DATA=2 및 "MSG_ERR_INVALID_PARAMETERS"

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Avamar 그리드에서 하나 이상의 클라이언트에 대한 백업을 복제하는 데 문제가 발생할 수 있습니다.

이 특정 상황은 VDP(VSphere Data Protection) 시스템에서 발생했습니다. 이 vdp-client-activity.log 는 다음과 같은 정보를 제공합니다. 

2016-10-03 04:11:03 avtar Info <6654>: Replicating backup 244, Label "somebackup-1475002800005", 26.27 GB 
2016-10-03 04:16:01 avtar Info <8688>: Status 2016-10-03 04:16:01, 26.00 GB (0 bytes, 0.00% new) 638MB 0% CPU client04_UATRUr8adn0H5ZysJuc9xw#244::/VMFiles/1/ 
2016-10-03 04:16:04 avtar Info <7694>: Server(vdp05.customer.com) not responding (possible network congestion?) (300 seconds) 
2016-10-03 04:16:04 avtar Info <7694>: Server(vdp06.customer.com) not responding (possible network congestion?) (300 seconds) 
2016-10-03 04:21:01 avtar Info <8688>: Status 2016-10-03 04:21:01, 26.00 GB (0 bytes, 0.00% new) 638MB 0% CPU client04_UATRUr8adn0H5ZysJuc9xw#244::/VMFiles/1/ 
2016-10-03 04:21:03 avtar Error <5445>: INTERNAL CYCLE ERROR: bad response in repldata DST_ADD_DATA: ADD_HASH_DATA=2 serial=114 seq=0 flags=R:N:1 kind=7 rsp=MSG_ERR_INVALID_PARAMETERS 
2016-10-03 04:16:04 avtar Info <7694>: Server(vdp05.customer.com) not responding (possible network congestion?) (300 seconds) 
2016-10-03 04:16:04 avtar Info <7694>: Server(vdp06.customer.com) not responding (possible network congestion?) (300 seconds) 
2016-10-03 04:47:43 avtar Info <7694>: Server(vdp05.customer.com) not responding (possible network congestion?) (300 seconds) 

Cause

반복되는 메시지 '네트워크 정체 가능성'이 반드시 연결 문제가 있음을 의미하지는 않습니다. 타겟 그리드가 예상대로 응답하지 않음을 나타냅니다.

이 오류 메시지는 대상 VDP에 ADD_DATA하기 위한 소스 그리드 요청에 문제가 있음을 설명하여 자세한 정보를 제공합니다.DST_ADD_DATA: ADD_HASH_DATA=2"로 변경되었습니다.

이 문제를 조사하는 동안 문제의 근본 원인을 식별할 수 없었습니다. "MSG_ERR_INVALID_PARAMETERS" 그러나 핵심 문구 INTERNAL CYCLE ERROR는 클라이언트 캐시가 손상될 수 있음을 나타냅니다.

Resolution

다음 방법을 사용하여 이 문제를 해결할 수 있습니다.
(정확하게 이와 같은 문제가 반복해서 발생하는 경우 Dell Technologies 지원 팀에 문의하십시오.)

1. 위에서 설명한 오류로 인해 백업이 실패한 클라이언트의 목록을 만듭니다.

2. 기존 복제 그룹을 복사하여 "테스트" 복제 그룹을 생성합니다. 또는 기존 복제 그룹을 임시로 수정하고 문제가 있는 클라이언트만 포함되도록 합니다.

3. 파일 생성 또는 편집 /usr/local/avamar/var/client/avtar.cmd  소스 그리드에서.

4. ' 항목을 추가합니다.--nocache'를 파일에 추가합니다.

이렇게 하면 복제 작업에서 클라이언트 캐시 파일을 활용할 수 없습니다.

클라이언트 캐시가 손상된 경우 클라이언트 캐시를 사용하지 않으면 클라이언트 캐시가 복제 실패의 원인인지 확인할 수 있습니다.

5. 문제 클라이언트 가 포함된 복제 작업을 실행하고 완료되도록 합니다.

복제에 실패하면 이 문서가 적용되지 않으며 추가 조사가 필요합니다. 

복제에 성공하면 문제가 있는 클라이언트에 대해 클라이언트 캐시를 다시 생성해야 합니다.

6. 클라이언트 캐시를 재생성하려면 다음을 수행합니다.

a. 편집하다 /usr/local/avamar/var/client/avtar.cmd 다시.

b. '--nocache' 항목을 입력하고 '로 바꿉니다.--clearcache'.

7. 클라이언트 캐시가 다시 생성되도록 테스트 복제 그룹을 다시 실행합니다. 작업이 완료될 때까지 기다립니다.

8. 삭제 avtar.cmd 파일 또는 편집 usr/local/avamar/var/client/avtar.cmd 를 제거하고 '--clearcache' 항목.  

주의: 이 단계를 놓치지 마십시오. 그렇지 않으면 모든 클라이언트에 대해 캐시가 다시 생성되고 다음 복제에 시간이 많이 걸립니다.
 

9. 복제해야 하는 모든 클라이언트가 포함된 원래 복제 그룹 구성으로 되돌립니다.

10. 예약된 복제가 정상적으로 실행되도록 허용합니다. 이제 캐시가 재생성된 클라이언트가 복제됩니다.

Affected Products

Avamar

Products

Avamar, Avamar Server
Article Properties
Article Number: 000165660
Article Type: Solution
Last Modified: 13 Oct 2025
Version:  8
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.