PowerProtect: DM5500: Slow backup and restore in Multi-VLAN config for NAS protection

Summary: Multi-VLAN configuration, where the specified VLAN at the asset level is not selected for Proxy to NAS array communication.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • In a Multi-VLAN configuration for NAS protection, the network interface selected for Proxy to NAS Array communication need not be part of the network or VLAN specified at the asset level.
  • In the current implementation, NAS Array communication will happen over one of the network interfaces associated with the NAS server (Unity or PowerStore) or access zone (in Isilon). If there is a failure in establishing communication to the NAS Array (that is mounting the share) at the proxy, then it is expected to retry this over other interfaces until it succeeds.    
  • If the selected network interface happens to be part of a slower network (For Example, Management VLAN) then backup/restore operations may take longer to complete. 
  • The selected network interface for NAS Array communication can be identified from the agent log (Nas_xxxxxyyyyy.log). That is a successful mount operation using mount -t nfs or mount.cifs.... confirms the network interface that is used for NAS Array communication. This network interface need not be part of the preferred network assigned at the asset level.

Cause

It is a limitation as no mechanism exists in PowerProtect Data Manager Appliance to choose a specific network or VLAN for Proxy to NAS Array communication.

Resolution

This issue will be fixed in a later release.
For a workaround, contact Dell Support.

    Affected Products

    PowerProtect DM5500
    Article Properties
    Article Number: 000220821
    Article Type: Solution
    Last Modified: 03 Oct 2024
    Version:  2
    Find answers to your questions from other Dell users
    Support Services
    Check if your device is covered by Support Services.