Isilon de 6.ª generación: La fuente de alimentación Gen6 muestra una cadena de ID de producto ilegible y los intentos de actualización de firmware pueden causar un bucle de arranque

Summary: Algunas fuentes de alimentación Gen6 se enviaron con datos dañados en su EEPROM de reanudación. Esto puede hacer que la cadena de ID del producto no se pueda leer y los intentos de actualización del firmware fallarán; Esta falla puede provocar que el nodo entre en un bucle de arranque. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms



La fuente de alimentación Gen6 con datos dañados en sus EEPROM de reanudación puede mostrar una cadena de ID dañada/ilegible. Esta cadena se puede encontrar en isi_hw_status:
 
PwrSupl: Slot1-PS0 (type=ARTESYN, fw=02.02)

En el ejemplo anterior, se muestra una fuente de alimentación no afectada. En una fuente de alimentación afectada, el texto rojo se puede reemplazar por caracteres no texto ilegibles o estar ausente por completo. Las fuentes de alimentación afectadas por este problema no pueden aceptar las actualizaciones de firmware; intentar actualizar su firmware puede provocar un bucle de arranque.

Cause

El fabricante de la fuente de alimentación envió una determinada cantidad de fuentes de alimentación con datos dañados en su EEPROM de reanudación interna. Estos datos dañados no afectan el funcionamiento de la fuente de alimentación, pero pueden causar que se muestre la cadena de ID del producto no válida y causar las fallas de actualización de firmware descritas anteriormente.

Resolution

NOTA:  Si un nodo queda atrapado en un bucle de arranque debido a este problema, quite la fuente de alimentación afectada. El nodo se inicia normalmente. Una vez que se inicie el nodo, reinstale la fuente de alimentación para restaurar la redundancia y solicite una fuente de alimentación de reemplazo. Cuando llegue, reemplace la fuente de alimentación según el procedimiento normal. En Gen6, ambas fuentes de alimentación para un par de nodos pares son administradas por el nodo en el compartimiento con numeración impar (1 y 3) para cada par. Si la extracción de la fuente de alimentación de un nodo afectado no rompe el bucle de arranque, reinstale la fuente de alimentación, espere unos segundos y, a continuación, quite la fuente de alimentación del nodo par.

Si el error se produce durante una evaluación del estado, comuníquese con el soporte.  El soporte determinará si el error es un falso positivo desencadenado por un script de evaluación del estado anterior o si se debe enviar una fuente de alimentación de reemplazo.  Si el error se produce en un nodo híbrido o de archivo de PowerScale (A300/A3000/H700/H7000), este es un falso positivo, ya que las fuentes de alimentación afectadas no se han enviado con estos nodos.

Additional Information

Para utilizar el script a fin de comprobar la PSU en un nodo no combinado:

Paso 1: Preparación
: asegúrese de que la consola shell del nodo esté disponible. Si el nodo se une previamente, presione CTRL-C en el asistente de configuración y, a continuación, presione Intro para utilizar el shell.
- Descargue el script desde el enlace anterior.
- Copie el script gen6_ps_check.py en una unidad USB; conecte la unidad al nodo.  Luego, monte la unidad. 
 
NOTA: Según la versión de software, la unidad USB puede aparecer como da0s1 en su lugar. Si es así, sustituya da0p1 por da0s1 en el siguiente comando.
 
# mount_msdosfs /dev/da0p1 /mnt


Paso 2: Ejecute el script
 
# cd /mnt  
# python gen6_ps_check.py

- El script imprimirá el resultado de la comprobación como aprobado o falló, como el ejemplo proporcionado anteriormente.

Paso 3: cierre
: suelte la unidad USB y vuelva a poner el nodo en el asistente:  
 
# cd /   
# unmount /mnt
# reboot


Opciones de script:

- Para alternar la impresión de varias líneas y más detallada:  
 
# python gen6_ps_check.py -v


- Para comprobar ambas PSU en un par par (una en el nodo local, una en el nodo par):  
 
# python gen6_ps_check.py -a

Affected Products

Isilon, Isilon Gen6
Article Properties
Article Number: 000057263
Article Type: Solution
Last Modified: 19 Dec 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.