Isilon Gen6: Zasilacz Gen6 pokazuje ciąg identyfikatora produktu niemożliwy do odczytania, a próby aktualizacji oprogramowania wewnętrznego mogą spowodować pętlę rozruchu

Summary: Niektóre zasilacze gen6 zostały dostarczone z uszkodzonymi danymi w wznowieniu pracy EEPROM. Może to spowodować, że ciąg identyfikatora produktu będzie niemożliwy do odczytania, a próby aktualizacji oprogramowania wewnętrznego zakończą się niepowodzeniem. Ta awaria może spowodować wejście węzła w pętlę rozruchu. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms



Zasilacz Gen6 ze uszkodzonymi danymi w wznowieniu pracy modułów EEPROM może wykazywać uszkodzony/nieczytelny ciąg identyfikatora. Ten ciąg można znaleźć w isi_hw_status:
 
PwrSupl: Slot1-PS0 (type=ARTESYN, fw=02.02)

Powyższy przykład przedstawia zasilacz, który nie uległ zmianie. W przypadku zasilacza, którego dotyczy problem, czerwony tekst może zostać zastąpiony nieczytelnymi znakami niewymienionymi lub całkowicie niedostępny. Zasilacze, których dotyczy ten problem, nie mogą akceptować aktualizacji oprogramowania wewnętrznego; próba aktualizacji oprogramowania wewnętrznego może spowodować zapętlony rozruch.

Cause

Producent zasilacza wysłał określoną liczbę zasilaczy z uszkodzonymi danymi w wewnętrznym wznowieniu EEPROM. Te uszkodzone dane nie wpływają na działanie zasilacza, ale mogą powodować wyświetlanie nieprawidłowego ciągu identyfikatora produktu i powodować błędy aktualizacji oprogramowania wewnętrznego opisane powyżej.

Resolution

UWAGA:  Jeśli węzeł zostanie wychwytany w pętli rozruchowej z powodu tego problemu, wyjmij zasilacz, którego dotyczy problem. Węzeł uruchamia się normalnie. Po uruchomieniu węzła ponownie zainstaluj zasilacz, aby przywrócić nadmiarowość, i poproś o wymianę zasilacza. Po przyjeździe należy wymienić zasilacz zgodnie z normalną procedurą. W genie 6 oba zasilacze dla pary węzłów równorzędnych są zarządzane przez węzeł we wnęce z numerem napędu optycznego (1 i 3) dla każdej pary — jeśli wyjęcie zasilacza z węzła, którego dotyczy problem, nie zepsuje pętli rozruchu, ponownie zainstaluj zasilacz, odczekaj kilka sekund, a następnie odłącz zasilacz węzła równorzędnego.

Jeśli błąd wystąpi podczas kontroli poprawności działania, skontaktuj się z działem pomocy technicznej.  Pomoc techniczna określi, czy błąd jest błędem fałszywie dodatnim wyzwalanym przez starszy skrypt kontroli stanu, czy też zasilacz musi zostać wysłany.  Jeśli błąd wystąpi w węźle hybrydowym lub archiwum PowerScale (A300/A3000/H700/H7000), jest to fałszywe ostrzeżenie pozytywne, ponieważ zasilacze, których dotyczy problem, nie zostały dostarczone z tymi węzłami.

Additional Information

Aby użyć skryptu do sprawdzenia zasilacza na odłączonym węźle:

krok 1: Przygotowanie
— upewnij się, że konsola powłoki węzła jest dostępna. Jeśli węzeł jest wstępnie dołączany, naciśnij klawisze CTRL-C w kreatorze konfiguracji, a następnie naciśnij klawisz Enter, aby użyć powłoki.
- Pobierz skrypt z powyższego łącza.
- Skopiuj skrypt gen6_ps_check.py na dysk USB; podłącz dysk do węzła.  Następnie zamontuj napęd. 
 
UWAGA: W zależności od wersji oprogramowania dysk USB może być wyświetlany jako da0s1. Jeśli tak, w poniższym poleceniu zastąp da0p1 da0s1.
 
# mount_msdosfs /dev/da0p1 /mnt


Krok 2: Uruchom skrypt
 
# cd /mnt  
# python gen6_ps_check.py

- Skrypt wydrukuje wynik sprawdzania jako powodzenie lub niepowodzenie, jak podano powyżej.

Krok 3: zawijanie
— zwolnij dysk USB i przywróć węzeł z powrotem do kreatora:  
 
# cd /   
# unmount /mnt
# reboot


Opcje skryptów:

- Przełączanie drukowania wielolinięowego, bardziej szczegółowego:  
 
# python gen6_ps_check.py -v


- Aby sprawdzić oba zasilacze w parze równorzędnej (jeden w węźle lokalnym, jeden w węźle równorzędnym):  
 
# python gen6_ps_check.py -a

Affected Products

Isilon, Isilon Gen6
Article Properties
Article Number: 000057263
Article Type: Solution
Last Modified: 19 Dec 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.