Isilon Gen6: Gen6 power supply shows unreadable Product ID string, and firmware update attempts may cause a boot loop

Summary: Some Gen6 power supplies were shipped with corrupted data in their resume EEPROM. This may cause their product ID string to be unreadable, and firmware update attempts will fail; this failure may cause the node to enter a boot loop. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Gen6 power supply with corrupted data in their resume EEPROMs may show a corrupted/unreadable ID string. This string can be found in isi_hw_status:
 

PwrSupl: Slot1-PS0 (type=ARTESYN, fw=02.02)


The above example shows an unaffected power supply. On an affected power supply, the word ARTESYN may be replaced by illegible non-text characters or be absent altogether. Power supplies affected by this issue are unable to accept firmware updates; attempting to update their firmware may result in a boot loop.

Cause

The power supply manufacturer shipped a certain number of power supplies with corrupted data in their internal resume EEPROM. This corrupted data does not affect power supply operation, but it may cause the invalid product ID string to be displayed, and causing the firmware update failures described above.

Resolution

NOTE:  If a node is caught in a boot loop because of this issue, remove the affected power supply. The node boots normally. Once the node is booted, reinstall the power supply to restore redundancy, and request a replacement power supply. When it arrives, replace the power supply per the normal procedure. In Gen6 both power supplies for a peer-node pair are managed by the node in the odd-numbered bay (1 and 3) for each pair - if removing the power supply from an affected node does not break the boot loop, reinstall the power supply, wait a few seconds, and then remove the peer node's power supply.


If the error occurs during a health check, please contact support.  Support will determine if the error is a false-positive triggered by an older health check script or if a replacement power supply must be shipped.  If the error occurs on a PowerScale Hybrid or Archive node (A300/A3000/H700/H7000), this is a false positive as the power supplies affected have not been shipped with these nodes.

Additional Information

To use the script to check the PSU on an unjoined node:

Step 1: Preparation
- Make sure the node's shell console is available. If the node is pre-join, hit CTRL-C at the configuration wizard, then hit Enter to use the shell.
- Download the script from the link above.
- Copy the script gen6_ps_check.py onto a USB drive; attach the drive to the node.  Then mount the drive. 
 

NOTE: Depending on software version, USB drive may show up as da0s1 instead. If so, substitute da0p1 for da0s1 in the below command.

 

# mount_msdosfs /dev/da0p1 /mnt


Step 2: Run the script
 

# cd /mnt  
# python gen6_ps_check.py


- The script will print check result as pass or fail, like the example provided above.

Step 3: wrap-up
- Release the USB-drive and bring the node back to the wizard:  
 

# cd /   
# unmount /mnt
# reboot


Script options:

- To toggle multi-line, more verbose print:  
 

# python gen6_ps_check.py -v


- To check both PSUs in a peer pair (one in local node, one in the peer node):  
 

# python gen6_ps_check.py -a

Affected Products

Isilon, Isilon Gen6
Article Properties
Article Number: 000057263
Article Type: Solution
Last Modified: 19 Dec 2025
Version:  5
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