No Auto Rotation on XPS 13 9365 and Latitude 7389 2-in-1 Systems

Summary: Touch screen does not auto-rotate on XPS 13 9365 and Latitude 13 7389 2-in-1 systems

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

The auto-rotate mode button may be missing from the Action Center on XPS 13 9365 and Latitude 13 7389 2-in-1 systems preventing the screen from automatically changing from portrait to landscape (or reverse) automatically.

Using Ctrl-Alt-> hot key combination to force the rotation works.

Reinstalling the sensor in Device Manager has no effect on the issue.

Note: This issue may also occur on other 2-in-1 models.

Cause

A fault in the Intel Integrated Sensor Solution driver.

Resolution

Reinstallation of the Intel Integrated Sensor Solution Driver will install the sensor drivers for the computer. Once you install this chipset package, all of the controls for screen rotation reappear. A pop up on the bottom right of the screen may appear as soon as the system is rotated. Click "Do not ask me again" in the popup. In Settings, turn off "Rotation Lock"  to enable auto rotation. If Rotation Lock is enabled, the system will stay in Tablet Mode.
 

Note: The rotation controls will be grayed out and when the display is tilted at an angle beyond 200–225 degrees transitioning to tablet mode.

The keyboard and touch pad will also be disabled. When transitioning back to notebook mode, the input devices are re-enabled when transitioning back within the 200–225 degree open angle.

Affected Products

Latitude 7389 2-in-1, XPS 13 9365 2-in-1
Article Properties
Article Number: 000145205
Article Type: Solution
Last Modified: 24 Apr 2025
Version:  7
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