NetWorker: Zálohování systému Windows selže s chybou "VSS OTHER: sow_create_sysset_snapshot: Službě VSS se nepodařilo zpracovat snapshot, error=0x0"

Summary: Klient Windows NetWorker během zálohování selže, což znamená, že se mu nepodařilo vytvořit snapshot VSS.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Během zálohování NetWorker klienta Microsoft Windows selžou důležité disky, které vyžadují použití služby Stínová kopie svazku (VSS), a zobrazí se následující zpráva: 
174424:save: Step (3 of 5) for PID-8568: Creating the snapshot for the selected save sets.
03/11/19 15:40:02.614837 UTF8 string for BCDPath is C:\Program Files\EMC NetWorker\nsr\tmp\xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxx\backcomp.xml
VSS OTHER: ERROR: VSS failed to process snapshot: 
03/11/19 15:40:02.630861 VSS OTHER: sow_create_sysset_snapshot: VSS failed to process snapshot, error=0x0
90108:save: Unable to save the SYSTEM STATE save sets: cannot create the snapshot.
03/11/19 15:40:02.630861 WriteTracker: nsrwriter_stop(8568:5204) -->.
03/11/19 15:40:02.630861 WriteTracker: nsrwriter_stop(8568:5204) error: NULL hProcess detected..
03/11/19 15:40:02.630861 WriteTracker: nsrwriter_stop(8568:5204) releasing hWriterMutex ....
03/11/19 15:40:02.630861 save workflow released nsrwriter lock.
03/11/19 15:40:02.630861 WriteTracker: nsrwriter_stop(8568:5204) <-- FALSE.
03/11/19 15:40:02.646091 WINDOWS ROLES AND FEATURES: sow_free_save called
03/11/19 15:40:02.646091 VSS USER DATA: sow_free_save called
03/11/19 15:40:02.646091 VSS OTHER: sow_free_save called
174918:save: Step (3 of 5) for PID-8568: Unable to complete the backup. See the savegrp log to track the closure steps of the backup.
175023:save: Unable to back up the save set 'pseudo_saveset'.

Cause

Jedná se o problém operačního systému, který brání vytvoření snapshotu.

Resolution

Zkontrolujte stav zápisů operačního systému:

1. Spusťte příkazový řádek (cmd) jako správce.
2. Spusťte nástroj diskshadow spuštěním příkazu:
diskshadow

3. Nástroj Stínový disk se spustí a příkazový řádek zobrazí hodnotu DISKSHADOW>.
4. Spuštěním následujícího příkazu si projděte seznam zapisovačů systému:
podrobné seznamy zapisovačů 

5. Tento výstup je dlouhý, takže může být nutné zvýšit vyrovnávací paměť příkazového řádku, aby se vše zaznamenalo.
6. Aby bylo vše zaznamenáno, měl by uživatel zkopírovat výstup do textového souboru. Spuštěním následujícího příkazu zaprotokolujte vše, co bylo spuštěno v nástroji diskshadow, v tomto případě potřebujeme pouze podrobný výstup zapisovače seznamu:
diskshadow /l "PATH_TO_OUTPUT_FILE"
Příklad:
diskshadow /l "C:\Windows\Temp\listoutput.txt"

7. Vyhledejte v souboru řetězec "[Does not exist]"
Příklad:
- Volumes affected by this component:
- \\?\Volume{9710a803-0000-0000-0000-501f00000000}\ [C:\]
- \\?\Volume{294e539b-7658-40d0-8751-e826e6d8813f}\ [D:\]
- \\HOSTNAME\SHARENAME\ [Does not exist]
POZNÁMKA: Jakákoli cesta UNC zde (počáteční \\hostname\názevsdíle – kde se jedná o hostitele v síti) není snapshotem VSS podporován.  Podívejte se na část výše ve výstupu, měla by se zobrazit dotčená komponenta a binární soubor zodpovědný.

Příklad:
+ Component "System Writer:\Win32 Services Files"
<snip>
- File List: Path = \\hostname\sharename\path\bin, Filespec = scd.exe
- Paths affected by this component:
<snip>
 - \\hostname\sharename\path\bin
Nejedná se o problém se softwarem NetWorker, ale o problém s operačním systémem. Příčinou je obvykle aplikace nainstalovaná v systému nebo vadná instalace. 
Pokud zálohování NetWorker fungovalo dříve, pak se zastavilo, je třeba provést hlubší analýzu na straně operačního systému. Protokol událostí systému Windows v prohlížeči událostí by měl poskytnout více podrobností, pokud je filtrován k tomuto datu, kdy k chybě došlo poprvé. Pro všechny trvalé problémy se službou VSS se doporučuje podpora společnosti Microsoft.

Additional Information

Affected Products

NetWorker

Products

NetWorker
Article Properties
Article Number: 000055493
Article Type: Solution
Last Modified: 27 Sept 2023
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.