Échec de la mise à niveau d’IDPA vCenter avec le message d’erreur « vCSACliInstallLogger - ERROR - vCenter Server Data Export failed »
Summary: Cet article de la base de connaissances vous guide dans la résolution d’un problème de mise à niveau de vCenter dû à un échec de l’exportation de la base de données vCenter Le problème peut être lié à une corruption de la base de données vCenter. ...
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Sur l’interface utilisateur ACM, vous remarquerez peut-être que le vCenter est en état d’échec.
Lorsque vous consultez le journal de mise à niveau de vCenter sous le répertoire « /data01/tmp/patch/logs/VCSA », le journal vcsaclientinstaller peut contenir les erreurs suivantes :
Progress: 42% Exporting VMware vCenter Server Database data...
2020-03-26 03:41:00,145 - vCSACliInstallLogger - ERROR - vCenter Server Data Export failed.
2020-03-26 03:41:00,145 - vCSACliInstallLogger - ERROR - Upgrade failed:
Status: ERROR
Progress: 42% Exporting VMware vCenter Server Database data...
Error:
Problem Id: None
Component key: upgrade_framework
Detail:
Error while exporting source SET tables: pg_dump: Message d’erreur du serveur : ERROR: invalid page in block 9 of relation base/16384/25164
Résolution : Lisez les fichiers journaux et corrigez les problèmes détectés dans vos tables SET sources.
2020-03-26 03:41:00,145 - vCSACliInstallLogger - INFO - Consultez le fichier /data01/tmp/patch/logs/vclogs/monitor-firstboot-progress-oczvL_.json sur l’ordinateur local ou le fichier /var/log/vmware/upgrade/export.json sur l’ordinateur distant pour plus d’informations.
De plus, sur le serveur vCenter, vous pouvez également consulter les journaux de mise à niveau situés dans le répertoire « /var/log/vmware/upgrade », qui contiennent peut-être le message d’erreur suivant :
VMware License Service data...
2020-03-26 17:09:01,732 - vCSACliInstallLogger - INFO - vCenter Server Data Export: Progress: 42% Exporting VMware vCenter Server Database data...
2020-03-26 17:09:12,296 - vCSACliInstallLogger - ERROR - vCenter Server Data Export failed.
2020-03-26 17:09:12,296 - vCSACliInstallLogger - ERROR - Upgrade failed:
Status: ERROR
Progress: 42% Exporting VMware vCenter Server Database data...
Error:
Problem Id: None
Component key: upgrade_framework
Detail:
Error while exporting source SET tables: pg_dump: Message d’erreur du serveur : ERROR: invalid page in block 9 of relation base/16384/25164
Résolution : Lisez les fichiers journaux et corrigez les problèmes détectés dans vos tables SET sources.
2020-03-26 17:09:12,296 - vCSACliInstallLogger - INFO - Consultez le fichier /data01/tmp/patch/logs/vclogs/monitor-firstboot-progress-tmcn2I.json sur l’ordinateur local ou le fichier /var/log/vmware/upgrade/export.json sur l’ordinateur distant pour plus d’informations.
2020-03-26 17:09:12,305 - vCSACliInstallLogger - INFO - Gathering VC support log bundle. This can take a few minutes.
2020-03-26 17:09:12,583 - vCSACliInstallLogger - INFO - Uninstalling vmware-upgrade-requirements-* on 192.168.100.99.
2020-03-26 17:09:13,881 - vCSACliInstallLogger - ERROR - (u'Failed to uninstall %(rpm)s on %(host)s: %(error)s', {'host': u'192.168.100.99', 'rpm': u'vmware-upgrade-requirements-*', 'error': CommandError(u"Failed to run and wait for command in guest with error 'Command '/bin/rpm' exited with non-zero status 1'",)})
postgres.log on the vcenter shows the following error message:
816 UTC 5e7ce0cc.7647 24294965 LOG: automatic analyze of table "VCDB.vc.vpx_event_arg" system usage: CPU 0.02s/1.53u sec elapsed 6.15 sec
2020-03-26 17:08:19.502 UTC 5e7ce180.2530 24295002 LOG: automatic analyze of table "VCDB.vc.vpx_event" system usage: CPU 0.00s/2.40u sec elapsed 2.79 sec
2020-03-26 17:08:58.326 UTC 5e7c377f.3892 0 VCDB vc LOG: unexpected EOF on client connection with an open transaction
2020-03-26 17:08:58.326 UTC 5e7c3796.3a7b 0 VCDB vc LOG: unexpected EOF on client connection with an open transaction
2020-03-26 17:08:58.327 UTC 5e7c3796.3a81 0 VCDB vc LOG: unexpected EOF on client connection with an open transaction
2020-03-26 17:09:09.530 UTC 5e7ce1b3.3c67 0 VCDB postgres ERROR: invalid page in block 9 of relation base/16384/25164
2020-03-26 17:09:09.530 UTC 5e7ce1b3.3c67 0 VCDB postgres STATEMENT: COPY vc.vpx_topn_past_month (counter_id, sample_time, integral_value) TO stdout;
SET zero_damaged_pages = on; select * from <corrupted table>; SET zero_damaged_pages = off;
VCDB=# select counter_id from vpx_topn_past_month;
ERROR: invalid page in block 9 of relation base/16384/25164
Cause
Une corruption de la base de données Postgres vCenter entraîne un échec de la mise à niveau de vCenter lors de la tâche d’exportation de la base de données.
Resolution
Étape 1 : Connectez-vous à l’interface utilisateur IDPA vCenter.
Étape 2 : Clonez la machine virtuelle vCenter.
Étape 3 : Effectuez une restauration de la machine virtuelle vCenter sur l’interface utilisateur ACM.
Étape 4 : Connectez-vous à la machine virtuelle vCenter via SSH et arrêtez le service vpxd.
Étape 5 : Connectez-vous à la base de données Postgres vCenter.
Étape 2 : Clonez la machine virtuelle vCenter.
- Cliquez avec le bouton droit de la souris sur la machine virtuelle VCSA, puis sélectionnez Clone to Virtual Machine.
- Choisissez le nom du clone, renseignez d’autres détails, puis cliquez sur OK.
Étape 3 : Effectuez une restauration de la machine virtuelle vCenter sur l’interface utilisateur ACM.
- Cliquez sur la case Troubleshooting Options. Cliquez sur Rollback for vCenter Upgrade.
Étape 4 : Connectez-vous à la machine virtuelle vCenter via SSH et arrêtez le service vpxd.
- service-control --stop vpxd
Étape 5 : Connectez-vous à la base de données Postgres vCenter.
- /opt/vmware/vpostgres/current/bin/psql -d VCDB -U postgres
- SET zero_damaged_pages = on;
- VACUUM FULL ANALYSE VERBOSE;
- REINDEX table vpx_topn_past_month;
- select * from vpx_topn_past_month;
- SET zero_damaged_pages = off;
Additional Information
Contactez le support VMware si le problème n’est pas résolu après avoir effectué les étapes ci-dessus.
Affected Products
Integrated Data Protection Appliance FamilyProducts
PowerProtect DP4400, PowerProtect DP5300, PowerProtect DP5800, PowerProtect DP8300, PowerProtect DP8800, PowerProtect Data Protection Software, Integrated Data Protection Appliance Family, PowerProtect Data Protection Hardware
, Integrated Data Protection Appliance Software
...
Article Properties
Article Number: 000173289
Article Type: Solution
Last Modified: 27 May 2025
Version: 3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.