Avamar: Troubleshooting Data Domain Integration Errors in the Avamar Administrator UI (Resolution Path)

Summary: This article aims to provide a basic understanding of the SNMP in the Avamar Data Domain integration. It also provides steps to resolve the issue.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

This is a reporting issue.

This issue should not have any impact on backups.

If backups are failing simultaneously when the Data Domain is reported as Unresponsive, stop following this article.

 

One or more of the following errors may appear in the Avamar Management Control Server (MCS) UI:
  • Error: Unable to get SNMP file system status
  • Error: Unable to get file system information
  • Error: Unable to get disk status
  • Error: Unable to retrieve ssh keys
  • Error: Synchronization of maintenance operations is off
  • Error: SNMP Status Unknown

Cause

Avamar uses Simple Network Management Protocol (SNMP) queries to Data Domain to retrieve DD statistics (such as serial number, disk status and so forth).

 

Avamar expects Data Domain to respond to SNMP queries within a specific time limit.
Due to various reasons (for example a busy or bad network), Data Domain takes longer to respond than this expected limit set by Avamar.
This can result in an invalid, false positive, status messages.

There are several scenarios that can cause SNMP Errors in an Avamar/Data Domain (DD) Integrations.

This document assists the reader with some of the most common problems and how to determine when and why the failure occurred.

Resolution

Validate that each troubleshooting step below is true for the environment.

Each step provides instructions or a link to a document in order to eliminate possible causes and take corrective action as necessary.

The steps are ordered in the most appropriate sequence to isolate the issue and identify the proper resolution. Do not skip a step.

 

Step 1: Log in to the Avamar Utility Node as admin, and load the admin keys. For instructions on loading keys see Avamar: How to Log in to an Avamar Server and Load Various Keys.

Note: The rest of this KB assumes that the admin keys are loaded.
 

Step 2: Verify that there are sufficient streams from Avamar to Data Domain per Avamar: Administrator UI Reports an incorrect Data Domain Status due to Insufficient Streams

Step 3: Verify that for Avamar 7.1.x grids that the SNMP trap host and port is configured correctly per Avamar: Administrator UI Reports Data Domain Status Unresponsive due to an Invalid SNMP trap host or trap post

Step 4: Verify that the Data Domain server is not too busy per Avamar: Administrator UI reports an incorrect Data Domain Status due to "System Too Busy"

Step 5: Verify that there are no SNMP configuration issues on the Data Domain server per Avamar: Administrator UI reports an incorrect Data Domain status due to SNMP configuration issues.

Step 6: Verify that the Data Domain is providing incorrect status due to network issues per Avamar: Administrator UI reports an incorrect Data Domain status due to firewall or port issues

Step 7: Verify that the Data Domain server is responding to SNMP requests in a timely manner per Avamar: Data Domain reports an incorrect status due to SNMP queries not responding in a timely manner

Step 8: Verify that the time on the Data Domain and the Avamar is correct and is not different per Avamar: Administrator UI Reports an incorrect Data Domain Status due to the Incorrect time on the DD

Note: The error message on the Avamar UI: The Avamar server's time is ahead of DD's.
 

Step 9: Verify that the Data Domain is not missing the ssh key from Avamar per Avamar: Administrator UI reports an incorrect Data Domain Status due to missing or incorrect SSH keys (Restricted Access)

Step 10: Verify that the ssh access from Avamar is not restricted to DD per Avamar: SSH to Data Domain from Avamar Server fails with ssh_exchange_identification error

Step 11: Verify that the SNMP requests from Avamar to the DD are not timing out, due to other application polling the DD per Avamar Administrator UI Reports an incorrect Data Domain status due to other Systems polling DD for SNMP

Step 12: Verify that the SNMP request to DD is not timing out due to space.log size being high on the DD per Avamar: Administrator UI reports an incorrect Data Domain status due to the size of the DD space.log

Step 13: Verify that the SNMP request to DD is not timing out due to ost.log size being high on the DD per Avamar: Administrator UI reports an Incorrect Data Domain status due to a large ost.log.

Step 14: Verify that the DD does not have an SNMP issue due to an unconfigured mail server per Data Domain: SNMP unresponsive on Data Domain due to the mail server being unconfigured

Step 15: Verify that the password for the ddboost user is not expired per Avamar: Administrator UI reports an incorrect Data Domain status due to an expired ddboost password

 

If the issue is not resolved using any of the solutions above, contact Dell Technologies Technical Support for further assistance.

Affected Products

Avamar, Avamar Server
Article Properties
Article Number: 000025660
Article Type: Solution
Last Modified: 11 May 2025
Version:  10
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