Dell Unity: Unity onbereikbaar na opnieuw opstarten van primaire SP tijdens upgrade
Summary: In dit artikel wordt uitgelegd waarom Unity Management Services onbereikbaar worden na het opnieuw opstarten van de primaire SP tijdens een upgrade. (Door gebruiker te corrigeren)
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Primaire SP wordt opnieuw opgestart tijdens het upgradeproces.
Unity Management Services raken onbereikbaar tijdens het opnieuw opstarten van de primaire SP van het code-upgradeproces.
Unity IP kan niet worden gepingd en Unisphere kan niet worden geladen.
De toegang tot data wordt niet beïnvloed.
Unity Management Services raken onbereikbaar tijdens het opnieuw opstarten van de primaire SP van het code-upgradeproces.
Unity IP kan niet worden gepingd en Unisphere kan niet worden geladen.
De toegang tot data wordt niet beïnvloed.
Cause
In Unity verwerkt de primaire SP beheerservices (het IP-adres).
Wanneer de Primaire SP opnieuw wordt opgestart, wordt een failoverboeking uitgevoerd van beheerservices naar Secundaire (peer) SP.
Probleem 1:
Als de secundaire SP niet is verbonden met hetzelfde beheernetwerk als de primaire, wordt het Unity IP-adres onbereikbaar wanneer de beheerservice overgaat.
Voorbeeld:
Vóór de upgrade:
Een tweede probleem kan zich voordoen wanneer de failover tussen SP's plaatsvindt en we het MAC-adres op de nieuwe SP vervalsen. Sommige gebruikersomgevingen pikken mogelijk het nieuwe "dubbele" MAC-adres op en blokkeren de toegang tot de switchpoort, waardoor de toegang verloren gaat.
Deze verbetering controleert op mogelijke verbindingsproblemen op de beheerpoorten. Bekijk Dell Unity: Healthcheck voorafgaand aan de upgrade wordt voltooid met waarschuwing: platform::check_management_port_2 (op te lossen door gebruiker)
dit waarschuwingsbericht geeft aan dat de Unity-array de beheernetwerkconnectiviteit van de peer Storage Processor (SP) niet kon bevestigen. De nieuwe Unity OE 5.3 PUHC-verbetering initieert een ARP-sonde (Address Resolution Protocol) naar het netwerk. Dit is om een eventueel connectiviteitsprobleem op de peer SP te bevestigen, in het geval dat beheerbewerkingen niet naar de peer SP kunnen worden overgezet.
De PUHC zendt een ARP-sonde uit in plaats van een standaard ARP-ping. Het IP-adres van het beheer is alleen actief op de primaire SP, niet op de peer. Dit is de reden dat de controle een ARP-sonde op de peer moet zijn. De niet-primaire (peer) SP heeft geen geconfigureerd IP-adres voor een standaard ARP. Het ARP-verzoek moet dus worden verzonden met 0.0.0.0 ingevuld en is een ARP-sonde.
Het waarschuwingsbericht treedt op als er geen reactie wordt ontvangen van de ARP-sonde.
Deze waarschuwing betekent niet dat de poortkoppeling voor één SP-beheerpoort vóór de upgrade niet beschikbaar was. Als dat het probleem was, zou de Pre-Upgrade Health Check het oppikken (zoals beschreven in het Dell artikel Dell Unity: Healthcheck mislukt met [Error code: platform::check_peer_management_port_link_2] (op te lossen door gebruiker)
Wanneer de Primaire SP opnieuw wordt opgestart, wordt een failoverboeking uitgevoerd van beheerservices naar Secundaire (peer) SP.
Probleem 1:
Als de secundaire SP niet is verbonden met hetzelfde beheernetwerk als de primaire, wordt het Unity IP-adres onbereikbaar wanneer de beheerservice overgaat.
Voorbeeld:
Vóór de upgrade:
- SP A is primair en SP B is secundair
- SP A is aangesloten op het beheernetwerk van waaruit toegang wordt verkregen tot Unisphere.
- SP B is niet verbonden met hetzelfde netwerk als SP A.
- SP B wordt primair en SP A wordt secundair.
- Aangezien beheerservices bij SP B zijn, is het Unity-beheer-IP onbereikbaar.
Een tweede probleem kan zich voordoen wanneer de failover tussen SP's plaatsvindt en we het MAC-adres op de nieuwe SP vervalsen. Sommige gebruikersomgevingen pikken mogelijk het nieuwe "dubbele" MAC-adres op en blokkeren de toegang tot de switchpoort, waardoor de toegang verloren gaat.
Opmerking: Een nieuwe verbetering van het hulpprogramma Pre-Upgrade Health Check (PUHC) is geïntroduceerd in Unity OE 5.3 en hoger.
Deze verbetering controleert op mogelijke verbindingsproblemen op de beheerpoorten. Bekijk Dell Unity: Healthcheck voorafgaand aan de upgrade wordt voltooid met waarschuwing: platform::check_management_port_2 (op te lossen door gebruiker)
Test of the management port configuration indicates there may be a problem with the management port VLAN settings that could cause loss of management functionality during storage processor reboots associated with the upgrade. Some valid network configurations can also make this test fail. Ensure that the alternate management port is properly configured. See KB#000066048 for recommended VLAN management port guidelines. You can safely ignore this warning if there is not a real issue.Schermafbeelding van de gebruikersinterface van PUHC-waarschuwing:
dit waarschuwingsbericht geeft aan dat de Unity-array de beheernetwerkconnectiviteit van de peer Storage Processor (SP) niet kon bevestigen. De nieuwe Unity OE 5.3 PUHC-verbetering initieert een ARP-sonde (Address Resolution Protocol) naar het netwerk. Dit is om een eventueel connectiviteitsprobleem op de peer SP te bevestigen, in het geval dat beheerbewerkingen niet naar de peer SP kunnen worden overgezet.
De PUHC zendt een ARP-sonde uit in plaats van een standaard ARP-ping. Het IP-adres van het beheer is alleen actief op de primaire SP, niet op de peer. Dit is de reden dat de controle een ARP-sonde op de peer moet zijn. De niet-primaire (peer) SP heeft geen geconfigureerd IP-adres voor een standaard ARP. Het ARP-verzoek moet dus worden verzonden met 0.0.0.0 ingevuld en is een ARP-sonde.
Het waarschuwingsbericht treedt op als er geen reactie wordt ontvangen van de ARP-sonde.
Deze waarschuwing betekent niet dat de poortkoppeling voor één SP-beheerpoort vóór de upgrade niet beschikbaar was. Als dat het probleem was, zou de Pre-Upgrade Health Check het oppikken (zoals beschreven in het Dell artikel Dell Unity: Healthcheck mislukt met [Error code: platform::check_peer_management_port_link_2] (op te lossen door gebruiker)
Resolution
Tijdens PUHC voorafgaand aan de upgrade:
Het onderstaande waarschuwingsbericht is een zachte waarschuwing en geen fout:
Een extra optie voor dat artikel is het opnieuw opstarten van de huidige primaire SP om bewerkingen voor failoverbeheer naar de peer-SP te failoveren. Beheerbewerkingen kunnen tot 10 minuten verloren gaan tijdens het failoverproces. Zodra de beheerbewerkingen zijn hersteld, controleert u of de peer-SP nu de primaire SP is. Als beheerbewerkingen met succes werken op SPA en SPB na failovertests, kan dit waarschuwingsbericht veilig worden genegeerd.
Tijdens de upgrade:
Deze waarschuwing kan worden genegeerd als deze pas halverwege de upgrade werd opgemerkt. Klik op de knop "Retry" om door te gaan met de upgrade.
Neem contact op met Dell Support en vermeld dit Knowledge Base-artikel, voor het geval de knop "Opnieuw proberen" niet werkt.
Na een geslaagde upgrade:
De onderstaande waarschuwing
Het onderstaande waarschuwingsbericht is een zachte waarschuwing en geen fout:
Warning Code: platform::check_management_port_2Gebruik een van de opties in het onderstaande artikel om beheerbewerkingen over te zetten naar de peer-SP om te testen of de peer-SP verbinding heeft met het netwerk, mislukt. Dell Unity: Een failover van Management Services (ECOM) uitvoeren (op te lossen door Dell)
Een extra optie voor dat artikel is het opnieuw opstarten van de huidige primaire SP om bewerkingen voor failoverbeheer naar de peer-SP te failoveren. Beheerbewerkingen kunnen tot 10 minuten verloren gaan tijdens het failoverproces. Zodra de beheerbewerkingen zijn hersteld, controleert u of de peer-SP nu de primaire SP is. Als beheerbewerkingen met succes werken op SPA en SPB na failovertests, kan dit waarschuwingsbericht veilig worden genegeerd.
Tijdens de upgrade:
Deze waarschuwing kan worden genegeerd als deze pas halverwege de upgrade werd opgemerkt. Klik op de knop "Retry" om door te gaan met de upgrade.
Neem contact op met Dell Support en vermeld dit Knowledge Base-artikel, voor het geval de knop "Opnieuw proberen" niet werkt.
Na een geslaagde upgrade:
De onderstaande waarschuwing
Warning Code: platform::check_management_port_2Kan veilig worden genegeerd als dit waarschuwingsbericht is ontvangen na een succesvolle upgrade naar Unity OE 5.3 of hoger.
Additional Information
Dit KB-artikel is van toepassing op alle primaire SP-reboots en niet alleen upgrades.
Voorbeelden van het probleem:
Voorbeelden van het probleem:
- In één geval werd één SP aangesloten op het beheernetwerk terwijl de andere SP-beheerkabel was aangesloten op een of andere iSCSI-switch.
- In een ander geval werd één SP aangesloten op een beheernetwerk terwijl de andere SP-beheerkabel was aangesloten op de switchpoort die verbinding maakte met een ander netwerk via een ander VLAN.
Affected Products
Dell EMC Unity FamilyProducts
Dell EMC Unity Family |Dell EMC Unity All Flash, Dell EMC Unity Family, Dell EMC Unity HybridArticle Properties
Article Number: 000066048
Article Type: Solution
Last Modified: 21 Jun 2024
Version: 8
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.