NetWorker: REST API backups queries time-out
Summary: NetWorker Representational State Transfer (REST) Application Programming Interface (API) operations are used to query backups. The REST API query fails with a time-out error.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
- You are attempting to query NetWorker backups with the REST API, but they are timing out on some resources.
- You are using the
/nwrestapi/v3/global/clients/client_id/backupsURL. - The resource being queried is for a VMware vCenter.
- Behavior is producible either scripted or with a single REST call.
- /nsr/logs/restapi/restapi.log may report status 500 (internal server error) for the resource being queried. This is a generic error message.
Cause
This behavior can occur when querying vCenters due to the number of backups and metadata being queried for a single resource.
If you are scripting the REST API commands and there are vCenters in the query, using the "/clients/client_id/backups" URL this behavior may appear on other resources as well due to potential memory leak.
Resolution
Use the following REST API call for querying VMware backups: https://NetWorker_Server_Name:9090/nwrestapi/v3/global/vmware/vcenters/Hypervisor_Resource_Name/protectedvms/VM_UUID/backups
Where Hypervisor_Resource_Name is the name of the vCenter as seen in NetWorker.
curl Example:
[root@nsr ~]# curl -k --user Administrator:'!Password1' "https://nsr.amer.lan:9090/nwrestapi/v3/global/vmware/vcenters/vcsa.amer.lan/protectedvms/503e7439-7053-9fc0-6c26-02f5f021b289/backups"
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 37215 0 37215 0 0 504k 0 --:--:-- --:--:-- --:--:-- 504k
{
"backups": [
{
"attributes": [
{
"key": "**backup start time",
"values": [
"1748912415"
]
},
{
"key": "*backup_device",
"values": [
"Data Domain"
]
},
{
*** REMOVED_JSON_CONTENT***
}
}
],
"count": 8
}
PostMan Example:
NOTE: Status 200 indicates that the command was received and responded correctly.
You can continue to use the
https://NetWorker_Server_Name:9090/nwrestapi/v3/global/clients/Client_ID/backups URL for traditional NetWorker clients.
Additional Information
NetWorker support can only handle break-fix issues with REST API and cannot support any custom scripts used to call REST API.
https://developer.dell.com/apis/2378/versions/v3/docs/GettingStarted.md
https://developer.dell.com/apis/2378/versions/v3/docs/GettingStarted.md
Affected Products
NetWorkerProducts
NetWorkerArticle Properties
Article Number: 000169971
Article Type: Solution
Last Modified: 03 Jun 2025
Version: 4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.