NetWorker : Expiration du délai des requêtes des sauvegardes de l’API REST

Summary: Expiration du délai des requêtes des sauvegardes de l’API REST

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • Vous tentez d’interroger les sauvegardes NetWorker avec l’API REST, mais elles expirent sur certaines ressources.
  • Vous utilisez l’URL /nwrestapi/v3/global/clients/client_id/backups .
  • La ressource interrogée concerne un VMware vCenter.
  • Le comportement peut être généré par script ou avec un seul appel REST.
  • /nsr/logs/restapi/restapi.log peut signaler l’état 500 (erreur de serveur interne) pour la ressource interrogée. Il s’agit d’un message d’erreur générique.

Cause

Ce comportement peut se produire lors de l’interrogation de vCenters en raison de la quantité de sauvegardes et de métadonnées interrogées pour une ressource unique.

Si vous scriptez les commandes de l’API REST et qu’il existe des vCenters dans la requête à l’aide de l’URL « /clients/client_id/backups », ce comportement peut également s’afficher sur d’autres ressources en raison d’une fuite de mémoire potentielle.

Resolution

Utilisez l’appel d’API REST suivant pour interroger les sauvegardes VMware : https:// NetWorker_Server_Name :9090/nwrestapi/v3/global/vmware/vcenters/Hypervisor_Resource_Name/protectedvms/VM_UUID/backups
Hypervisor_Resource_Name est le nom du vCenter, comme indiqué dans NetWorker.

Exemple:
kA23a0000000BiWCAU_2_0
Remarque : Status 200 indique que la commande a été reçue et a répondu correctement.

Vous pouvez continuer à utiliser l’URL https:// NetWorker_Server_Name :9090/nwrestapi/v3/global/clients/Client_ID/backups pour les clients NetWorker traditionnels.

Additional Information

La prise en charge de NetWorker peut uniquement gérer les problèmes de panne/réparation avec l’API REST et ne peut pas prendre en charge les scripts personnalisés utilisés pour appeler l’API REST. 

https://developer.dell.com/apis/2378/versions/v3/docs/GettingStarted.md

Affected Products

NetWorker

Products

NetWorker
Article Properties
Article Number: 000169971
Article Type: Solution
Last Modified: 03 Jun 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.