NetWorker: Time-out voor REST API-back-ups

Summary: Time-out voor REST API-back-ups

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • U probeert NetWorker back-ups op te vragen met REST API, maar er wordt een time-out uitgevoerd voor bepaalde resources.
  • U gebruikt de URL /nwrestapi/v3/global/clients/client_id/backups .
  • De resource die wordt opgevraagd, is voor een VMware vCenter.
  • Het gedrag is productiebaar met een script of met één REST-oproep.
  • /nsr/logs/restapi/restapi.log meldt mogelijk status 500 (interne serverfout) voor de bron die wordt gevraagd. Dit is een generieke foutmelding.

Cause

Dit gedrag kan zich voordoen bij het opvragen van vCenters vanwege de hoeveelheid back-ups en metadata die voor één bron worden opgevraagd.

Als u de REST API-opdrachten scriptt en er vCenters in de query zijn met behulp van de URL "/clients/client_id/back-ups", kan dit gedrag ook worden weergegeven op andere bronnen als gevolg van mogelijk geheugenlek.

Resolution

Gebruik de volgende REST API-aanroep voor het opvragen van VMware-back-ups: https:// NetWorker_Server_Name:9090/nwrestapi/v3/global/vmware/vcenters/Hypervisor_Resource_Name/protectedvms/VM_UUID/backups
Waarbij Hypervisor_Resource_Name de naam is van het vCenter zoals wordt weergegeven in NetWorker.

Voorbeeld:
kA23a0000000BiWCAU_2_0
Opmerking: Status 200 geeft aan dat de opdracht is ontvangen en correct is beantwoord.

U kunt de URL van de https:// NetWorker_Server_Name:9090/nwrestapi/v3/global/clients/Client_ID/back-ups blijven gebruiken voor traditionele NetWorker-clients.

Additional Information

NetWorker-support kan alleen probleemoplossingsproblemen oplossen met REST API en kan geen aangepaste scripts ondersteunen die worden gebruikt om REST API aan te roepen. 

https://developer.dell.com/apis/2378/versions/v3/docs/GettingStarted.md

Affected Products

NetWorker

Products

NetWorker
Article Properties
Article Number: 000169971
Article Type: Solution
Last Modified: 03 Jun 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.