IDPA: Geen toegang tot ACM Upgrade UI vanwege upgradevalidatie met bericht 'omleiding mislukt'

Summary: In dit artikel wordt een scenario beschreven tijdens het validatieproces van de IDPA-upgrade waarbij de omleiding van de gebruikersinterface van de ACM-upgrade mislukt. Dit kan gebeuren als poort 9443 is geblokkeerd op de netwerkfirewall tussen het systeem dat toegang heeft tot de ACM en ACM. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Controleer of het extraheren van het upgradebestand op ACM is geslaagd.

Meld u aan bij de ACM met PuTTY of SSH als rootgebruiker en voer de volgende opdracht uit:

cat /data01/tmp/patch/logs/extract.log

05/01/21 06:43:33 ************ Executing extract.sh ************

05/01/21 06:43:34 Dataprotection upgrade rpm not found.

05/01/21 06:43:34 Deploying dataprotection-upgrade binary in tomcat.

05/01/21 06:44:08 Checking for the mandatory files in tar

05/01/21 06:44:08 Creating second instance of tomcat

05/01/21 06:44:41 Successfully created second tomcat instance

Controleer of het maken van de tweede upgrade van het Tomcat-proces is geslaagd:

tail -5 /data01/tmp/patch/logs/tomcat_creation.log

05/01/21 06:44:41 Upgrade war exists in old tomcat. Removing war

05/01/21 06:44:41 Successfully deleted dataprotection upgrade war from old tomcat

05/01/21 06:44:41 Dataprotection upgrade directory exists in old tomcat. Removing war

05/01/21 06:44:41 Successfully deleted dataprotection upgrade directory from old tomcat

05/01/21 06:44:41 Successfully created second tomcat instance

Controleer of ACM luistert op poort 9443 met behulp van de volgende opdracht:

netstat -apn |grep 9443

Controleer of de upgradeservice actief is met behulp van de volgende opdracht:

service dataprotection_webapp_upgrade status

dataprotection_webapp_upgrade.service - SYSV: Apache Tomcat init script

   Loaded: loaded (/etc/init.d/dataprotection_webapp_upgrade)

   Active: active (exited) since Sat 2021-05-01 06:44:12 PDT; 4 days ago

  Process: 17035 ExecStart=/etc/init.d/dataprotection_webapp_upgrade start (code=exited, status=0/SUCCESS)

In een ander gebruiksscenario werden de volgende berichten genoteerd op de ACM upgrade-utility.log:

grep -i "java.net.ConnectException" /data01/tmp/patch/logs/upgrade-utility.log

2020-10-16 10:59:41,576 ERROR [https-jsse-nio-8543-exec-8]-util.RestUtil: Error occured while executing REST request. due to java.net.ConnectException: Connection timed out (Connection timed out)

Controleer of poort 9443 open is op de netwerkfirewall tussen het systeem dat toegang heeft tot de ACM en de ACM zelf.

Cause

Poort 9443 is geblokkeerd op de netwerkfirewall tussen het systeem dat toegang heeft tot de ACM en de ACM, waardoor dit probleem is ontstaan.

Resolution

Opmerking: De goidpa tool kan u meer informatie geven over dit probleem. Volg het onderstaande artikel om de goidpa tool: PowerProtect Data Protection Appliance: GoIDPA-tool

Voer de volgende opdracht uit op de ACM:
./goidpa system upgrade-port-check

Hiermee kunt u testen of poort 9443 bereikbaar is vanaf uw systeem.


Oplossing:

Poort 9443 moet worden geopend op de netwerkfirewall tussen het systeem dat toegang heeft tot de ACM-gebruikersinterface en de ACM-VM. 


Tijdelijke oplossing:

Het is mogelijk om een tunnel te maken op PuTTY om port forwarding als tijdelijke oplossing uit te voeren.

  1. Klik met de rechtermuisknop op PuTTY en ga naar Verbinding >SSH-tunnels >
  2. Voer de gegevens in de volgende indeling in:
Source Port 443

Destination IP: ACM Public IP Address

Destination Port: 443
  1. Klik op Add (Toevoegen)
  2. Voeg de tweede poorttunnel voor 9443 toe volgens de onderstaande gegevens en klik op Toevoegen
Source Port 9443

Destination IP: ACM Public IP Address

Destination Port: 9443

PUTTY-schermafbeelding van tunnelconfiguratie.  

  1. Open de IDPA Upgrade UI op de volgende URL:
https://localhost:9443/dataprotection-upgrade

Affected Products

Integrated Data Protection Appliance Family
Article Properties
Article Number: 000186345
Article Type: Solution
Last Modified: 30 May 2025
Version:  9
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.