OMSA: Web UI fails to load when the hostname contains an underscore character

Summary: These are the instructions for restoring access to the OpenManage Server Administrator (OMSA) web interface on a server with an underscore in its hostname.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

The OMSA web interface is inaccessible on a server where the hostname contains an underscore.

For example, the hostname of the server is "FS_1.domain.local."

The message received is usually "This site can't be reached" or "ERR_CONNECTION_CLOSED."

The DSM SA Connection Service is running and listening for connections on port 1311 as expected.

Cause

Underscores are not a valid character for Domain Name System (DNS) hostnames, as documented in RFC 1912.

https://datatracker.ietf.org/doc/html/rfc1912#section-2.1This hyperlink is taking you to a website outside of Dell Technologies.

As a result, OMSA is unable to generate a self-signed certificate during installation and starts its services without a valid TLS configuration. The connection service still runs and binds to port 1311 during startup but does not accept connections.

Resolution

Option A
Change the name of the server to a new name that only contains letters, numbers, or hyphens, then uninstall and reinstall OMSA.
 
Option B
Install a valid certificate and access OMSA by IP address instead of by hostname. Running the following OMConfig command on the affected server creates a new self-signed certificate:

omconfig preferences webserver attribute=gennewcert cn=<servername> org=Dell ou=ESG location=RoundRock state=TX country=US validity=3650 keysize=2048 algorithm=SHA512 webserverrestart=true

 
Replace "<servername>" with any supported value. The simplest option is to use the server's current name with any underscores removed.

Affected Products

OpenManage Server Administrator
Article Properties
Article Number: 000221443
Article Type: Solution
Last Modified: 10 Apr 2025
Version:  4
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