VxRail: Fail to add iDRAC user in VxRail plugin UI.

Summary: How to recover a failure to add an iDRAC user in vCenter (iDRAC version >= 4.22.00.201)

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms



Add a new Integrated Dell Remote Access Controller (iDRAC) user in vCenter UI fails with error message "Running script error: Script output fail: 400 Client Error...."

Sample screenshot when failed to add a user with the name "user" and Administrator privilege to ID 4:

Screenshot of error adding iDrac user 

When adding iDRAC user fails, login to iDRAC web UI, the new user is created but disable, and user role is "none.

Sample screenshot on iDRAC UI > Settings > Users tab > Local Users:

Screenshot of user showing none 

On VxRail plugin GUI, the user is added but the privilege is set to "idrac.user.role.NONE."

Sample screen shot on vCenter > Hosts and Clusters > DataCenter > VxRail Cluster > Node > Configure > VxRail > iDRAC Configuration > Users:

Screenshot from vSphere showing user role none 

This issue occurs when adding an iDRAC user in the VxRail plugin UI, and the provided password does not meet the needs from iDRAC.

Cause

This issue happens because the password used to create the account does not comply with the requirement of password complexity from iDRAC.

For example, starting from iDRAC version 4.22.00.201, the requirement of password complexity is more strict than in the previous version.

Resolution

Use the following steps to fix the partially added user in iDRAC :

  1. Log in to the iDRAC web UI with root user or any user with administrator privilege
  2. Do an iDRAC reset (iDRAC > Maintenance > Diagnostics > Reset iDRAC) to make sure the all configuration displayed on the iDRAC navigator is correct.
  3. Edit the newly added user in iDRAC, change the password until it can meet the limitation, and ensure all the x in the below picture are resolved. The requirements may vary from one version to another version. 
Screenshot showing passwords rules
  1. Change the User Role to Administrator and save.
Set the role to administrator
  1. Double check the User Role in both iDRAC and vCenter, make sure the user privilege is changed to "Administrator":
Screenshot showing the user role set to administrator
  1.       If the above process does not address the issue, contact Dell Support for other workarounds.

Additional Information

  • The default ID for a new iDRAC user is automatically chosen, and it is an unused ID.
Screenshot showing user ID
  • Verify that the new username is not in use before adding the new user in vCenter.

Refer to this video:

Products

VxRail, VxRail Appliance Series, VxRail Software
Article Properties
Article Number: 000180902
Article Type: Solution
Last Modified: 20 Feb 2025
Version:  4
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