Dell Command Monitor Service Becomes Unresponsive or Fails to Start

Summary: This article provides information about Dell Command | Monitor (DCM) service becoming unresponsive or fails to start because of System Management Device.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Affected Products:

  • Dell Command | Monitor

Symptoms:

  • DCM services become unresponsive or fail to start
  • WMI queries consistently fail
  • Event logs may show WMI or service-related errors
  • The device System Management Device appears in Device Manager

Cause

The System Management Device driver, when present, consumes system-level resources required by DCM services, particularly those relying on WMI (this results in conflict and eventual failure of the services).

Resolution

Disable the conflicting driver using the PowerShell script below. This script can be deployed across devices using Microsoft Intune or another device management platforms.

# Specify the FriendlyName of the devices you want to disable
$friendlyName = "*System Management Device*"

# Get the InstanceIDs of the devices with the specified FriendlyName
$instanceIds = Get-PnpDevice -FriendlyName $friendlyName | Select-Object -ExpandProperty InstanceId

# Display the InstanceIDs for reference
Write-Output "InstanceIDs: $($instanceIds -join ', ')"

# Disable each device with the obtained InstanceIDs 
foreach ($instanceId in $instanceIds) { PnpUtil /disable-device $instanceId Write-Output "Device with InstanceID $instanceId has been disabled." }
Note: Administrator privileges are required. Ensure the PowerShell execution policy allows running this script.

Affected Products

Dell Command | Monitor
Article Properties
Article Number: 000320905
Article Type: Solution
Last Modified: 15 May 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.