Dell Laptop Battery Always in Use if Connected to P3424WEB Monitor Using USB-C

Summary: The following article provides information about the laptop battery draining while connected to the Dell P3424WEB external monitor using USB Type-C. This is seen on Dell Pro Plus and Pro Premium laptops that have their AC adapter connected. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

The battery on the Dell Pro Plus or Pro Premium laptop continues to discharge with the AC adapter connected. This happens when the P3424WEB external monitor has its own power source and is connected over a USB Type-C cable to the laptop.

Affected Platforms:

  • Dell P3424WEB
  • Dell Pro 13 Premium PA13250
  • Dell Pro 14 Plus PB14250
  • Dell Pro 14 Premium PA14250

Cause

A power delivery (PD) communications gap between the monitor and platform means that it fails to negotiate a power contract over the USB-C cable. This prevents them from working or charging correctly.

Resolution

Note: Before starting the update, perform the following:
  1. Back up all personal data. For more information, refer to: Back Up and Recovery

  2. Connect the AC adapter.

Resolve this issue by updating the firmware on the monitor, or updating the laptops BIOS to the most recent version:

Update the monitors firmware:

Updating the firmware to version M2T108 on the monitor resolves the issue. To download and install the Dell_P3424WEB_FWUpdate_M2T108_Windows.exe file, refer to: Driver Update Guide

Update the laptops BIOS:

Updating the BIOS to version 2.7.4 or later on the laptop resolves the issue. To install the Dell_Pro_PA13250_PA14250_PB13250_PB14250_PB16250_2.7.4.exe file, refer to: BIOS Update Guide

Affected Products

Dell Pro 13 Premium PA13250, Dell Pro 14 Premium PA14250, Dell Pro 14 Plus PB14250, Dell P3424WEB
Article Properties
Article Number: 000385683
Article Type: Solution
Last Modified: 11 Dec 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.