Data Domain High Availability: Error "Failed to configure HA: peer node locking id <> does not match with ELMS license file" running 'ha create peer'

Summary: When requesting license for a HA system, make sure that you send the serial number of both the heads to the licensing team. 'ha create peer' fails with the following error "Failed to configure HA: peer node locking id <> does not match with ELMS license file" ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

License was requested for the first head only.
Running elicense show will tell if the license is available, but will not tell if its the correct license:
 
kA2f1000000L4u2CAC_3_0


The following error appears while running the ha create peer command:
 
**** Failed to configure HA: peer node locking id <> does not match with ELMS license file
 
kA2f1000000L4u2CAC_3_1

Cause

License has to be applied on the first head only.
If you had requested for a license with the serial number of the first head, then you will see error "locking ID <> does not match".

Resolution

To resolve the issue send the serial number of both the heads to the licensing team.
Specify that the license is for a HA system.
Get the new license file and replace the old one.

To update the license: 
  1. Transfer the license file .lic file to /ddvar
  2. Run the following command:
elicense update filename

Additional Information

License has to be applied on the first head only.

Affected Products

Data Domain

Products

Data Domain
Article Properties
Article Number: 000059762
Article Type: Solution
Last Modified: 09 Sept 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.