NetWorker : Fichiers log et informations à collecter et à fournir pour la prise en charge des problèmes généraux de NetWorker
Summary: Instructions sur les données généralement demandées et requises lors de l’envoi ou de la transmission d’un dossier de dépannage NetWorker.
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Symptoms
Notez que la technologie est déterministe : par définition, un échec dans lequel elle fonctionnait auparavant nécessite un changement. Un composant nouvellement implémenté sans historique de travail est considérablement différent du dépannage.
Modifications évidentes et identifiables :
Modifications évidentes et identifiables :
- Modification de la version du logiciel ou de la configuration
- Modification ou reconfiguration du matériel ou du transport
- Événements environnementaux tels que les pannes d’alimentation, les pannes de transport, les pannes de disque
- Corruption des ressources logicielles ou des systèmes de fichiers
- Opérations conflictuelles sur le réseau, le SAN ou les hôtes
- Reconfiguration du transport ou des hôtes par d’autres équipes
- Augmentation du volume de données ou du trafic de transport
- Événements environnementaux non catastrophiques qui ne déclenchent pas d’alertes
Lors de la préparation d’un problème pour une révision étendue et un travail de dépannage technique, assurez-vous que les directives générales suivantes sont respectées. Ces éléments permettent de s’assurer que suffisamment de données sont collectées mécaniquement et que les bonnes questions sont posées pour qualifier correctement le problème.
Cause
Définissez clairement le problème :
- Qu’est-ce que l’opération ou l’attribut défaillant, déviant ou qui fait l’objet de questions ? Quels sont les détails de la séquence d’échecs disponibles ?
- Quels composants et chemins de données spécifiques sont impliqués, par exemple les fichiers binaires, les commutateurs SAN/réseau ? Versions logicielles ? Types ou instances de stockage ?
- OÙ le problème se produit-il dans le workflow normal ? Si la même opération est tentée à l’aide d’un workflow différent, les résultats diffèrent-ils ?
- QUAND le problème s’est-il produit pour la première fois ? Combien de temps dure-t-il ? Quelles dates/heures s’est-elle produite depuis ? Des modifications récentes ont-elles été identifiées ?
- COMMENT le problème se produit-il : de manière cohérente ou intermittente ? Comment le problème est-il atténué une fois qu’il se produit ?
- Qui sont les hôtes concernés par le problème et quelles sont leurs propriétés (type d’hôte NetWorker, version NetWorker, nom, IP, système d’exploitation, processeur, etc.) ?
- POURQUOI certains composants sont-ils affectés, alors que ce n’est pas le cas de composants similaires ? Quelles différences existent entre les composants non affectés, mais semblables à ceux des composants ?
Resolution
JOURNAUX GÉNÉRIQUES
La plupart des journaux NetWorker peuvent être collectés à partir des serveurs, nœuds de stockage et/ou clients NetWorker Windows et Linux à l’aide de l’utilitaire NSRGET. L’utilitaire peut être téléchargé à partir de :
https://central.dell.com/solutions/Networker-Tools
1. Extrayez l’utilitaire NSRGET vers n’importe quel répertoire
temporaire 2. Vous trouverez des instructions sur l’utilisation de NSRGET dans : NetWorker : Utilisation de l’outil
de collecte de données NSRGet NetWorkerLes journaux de la base de connaissances suivants sont utilisés par NetWorker : NetWorker : Fichiers log et emplacements
Collectez les éléments suivants à partir de tous les hôtes NetWorker impliqués (y compris les nœuds de serveur et de stockage) :
- Fichiers de débogage NetWorker : liste des répertoires de [nsr]/debug
- Ce répertoire doit être vide. S’il existe des fichiers sous /nsr/debug qui coïncident avec la date à laquelle un problème s’est produit, cela peut indiquer un problème.
- Fichiers centraux NetWorker :
- Linux : /nsr/cœurs
- Windows : C :\Program Files\EMC NetWorker\nsr\cores
- Logs d’application NetWorker : zip de [nsr]/apps ; zip de [nsr]/applogs ; zip de [nsr]/rmagentps/logs ; bundle de [nsr]/logs/lib*, nsrbr*, nsrsnap**
- Logs NetWorker : [nsr]/logs/daemon.raw, [nsr]/logs/networkr.raw
- Configuration du client NetWorker : zip de [nsr]/res/nsrladb, [nsr]/res/servers file (peut ne pas exister), [nsr]/res/nsrdb (si le serveur NetWorker)
- Ils sont collectés par l’utilitaire NSRGET.
- Script de démarrage : Solaris > Linux - /etc/init.d/networker, HPUX - /sbin/init.d/networker
- Logs des règles de sauvegarde :
- Linux : /nsr/logs/policy/POLICY_NAME/WORKFLOW_NAME
- Windows : C :\Program Files\EMC NetWorker\nsr\logs\policy\POLICY_NAME\WORKFLOW_NAME
- Version et build netWorker : NetWorker : méthodes d’identification de la version du logiciel NetWorker
- Correctifs connus installés pour NetWorker
- Système d’exploitation, édition, niveau de correctif, processeur et largeur de bits (32/64 bits)
- Linux : cat /etc/*release ; uname -m
- Windows : systeminfo | findstr « OS Type »
- NSRGET ou EMCREPORTS détaille également la version du système d’exploitation et l’architecture système.
- Utilitaire EMC Reports : https://www.dell.com/support/home/en-us/product-support/product/emcreports/drivers
- EMC Reports collecte des informations supplémentaires sur l’hôte, y compris les détails complets du système d’exploitation et la configuration, les messages du système d’exploitation ou les journaux d’événements ; certaines de ces informations sont également collectées dans NSRGET ; tandis qu’EMC Reports utilise davantage de logs spécifiques au fonctionnement. Les rapports EMC peuvent être collectés en conformité avec NSRGET ou sur un système sur lequel aucun logiciel client NetWorker n’est installé. par exemple, une machine virtuelle VMware sauvegardée par vProxy.
- Vidages mémoire : NetWorker : Dépannage des vidages mémoire du processus
- Pour les problèmes de résolution de noms suspects : NetWorker : Bonnes pratiques en matière de résolution des problèmes de noms
Collectez les éléments suivants à partir de NetWorker Server uniquement :
- Base de données de ressources NetWorker : Copie compressée de [nsr]/res/nsrdb
- Base de données des médias NetWorker : Exportation de la base de données des médias NetWorker à l’aide de nsrmmdbasm
- NSRGET collecte la plupart des logs nécessaires ; toutefois, il ne collectera pas :
- Logs AUTHC (authentification) :
- Linux : /nsr/logs/authc
- Windows : C :\Program Files\EMC NetWorker\nsr\authc-server\tomcat\logs
- Logs netWorker Management Console (NMC) (gstd) :
- Linux : /opt/lgtonmc/logs/
- Windows : C :\Program Files\EMC NetWorker\Management\GST\logs
- Logs de l’interface utilisateur Web NetWorker (NWUI) :
- Linux : /opt/nwui/logs
- Windows : C :\Program Files\EMC NetWorker\nwui\logs
- Logs AUTHC (authentification) :
- Commande de découverte NetWorker : sortie inquire -lc
- Interrogation du bus NetWorker : Sortie lusbinfo/lusbinfo -v
- Sorties de la commande SJI NetWorker : sjisn [x.y.z], sjirdtag [x.y.z], sjirjc [x.y.z] (où x.y.z correspond à une adresse SCSI OU à un descripteur de fichier de périphérique)
- Sorties de la commande CDI NetWorker : cdi_inq -f [dev] -v, cdi_get_config -f [dev] -v, cdi_get_status -f [dev] -v, cdi_get_blocksize -f [dev] -v (où dev est la poignée de fichier du périphérique)
- Récapitulatif de l’état du périphérique NetWorker et du montage : nsrmm
- Résultat de l’auto-changeur simple NetWorker : nsrjb -C [jukebox_name]
- Détails du disque NetWorker : listes de répertoires récursifs pour toute structure AFTD/DD/FTD affectée, ainsi que les détails du périphérique de disque et de sa méthode de connexion à l’hôte.
- Système d’exploitation, édition, niveau de correctif, processeur et largeur de bits (32/64 bits)
- Linux : cat /etc/*release ; uname -m
- Windows : systeminfo | findstr « OS Type »
- NSRGET ou EMCREPORTS détaille également la version du système d’exploitation et l’architecture système.
- Les rapports NSRGET et/ou EMC sont recommandés pour les engagements de support.
Collectez les éléments suivants à partir de n’importe quel hôte NetWorker License Manager concerné :
- Résultat de la commande licensing : nsrlic -C
- Base de données de licences NetWorker : zip de [nsr]/res/lgtolm.res, [nsr]/res/lictype.res, [nsr]/logs/lgtolmd.log, [nsr]/logs/license*
- Système d’exploitation, édition, niveau de correctif, processeur et largeur de bits (32/64 bits)
- Linux : cat /etc/*release ; uname -m
- Windows : systeminfo | findstr « OS Type »
- NSRGET ou EMCREPORTS détaille également la version du système d’exploitation et l’architecture système.
- Journal de la console de gestion (gstd.raw- idéalement, rendu) :
- Linux - /opt/lgtonmc/logs
- Windows : [chemin d’installation]\Management\GST\logs
- NetWorker : utilisation de nsr_render_log
- Version NMC comprenant le numéro de build
- Version Java JRE Oracle : https://www.java.com/en/download/help/version_manual.html
- NetWorker Runtime Environment (NRE) :
- Linux :
- rpm -qa | grep nre
- /opt/nre/java/latest/bin/java -version
- Windows :
- La version Java est répertoriée sous : C :\Program Files\NRE\java\jre#.#.#_###
- Si plusieurs dossiers Java sont répertoriés, cochez S ystem Environment Variable JAVA_HOME ou NSR_JAVA_HOME pour quel chemin est actuellement utilisé par NetWorker.
- La version NRE est répertoriée dans le Panneau de configuration, sous Programmes et fonctionnalités.
- La version Java est répertoriée sous : C :\Program Files\NRE\java\jre#.#.#_###
- Linux :
- Fichier De démarrage Web Java : [nmc]/web/gconsole.jnlp
- Fichier de configuration NMC : [nmc]/etc/gstd.conf
- Bundles de logs : NVP-vProxy : Collecte d’un bundle pour vProxy
- Outil ProxyHC (contrôle d’intégrité) : NVP-vProxy : Utilisation de l’outil de contrôle d’intégrité ProxyHC sur l’appliance vProxy
Affected Products
NetWorkerProducts
NetWorker SeriesArticle Properties
Article Number: 000079239
Article Type: Solution
Last Modified: 26 Sept 2023
Version: 4
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