NetWorker: Pliki dziennika i informacje do zebrania i zapewnienia pomocy technicznej w przypadku ogólnych problemów z NetWorker

Summary: Wskazówki dotyczące danych, które są zazwyczaj wymagane i wymagane podczas przesyłania lub przekazania sprawy rozwiązywania problemów NetWorker.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Należy pamiętać, że technologia jest deterministyczne — z definicji coś, co nie działa w miejscu, w którym wcześniej działało, wymaga zmiany. Nowo wdrożony komponent bez historii pracy różni się znacząco od rozwiązania problemu.

Oczywiste i możliwe do zidentyfikowania zmiany:
  • Zmiana wersji oprogramowania lub konfiguracji
  • Zmiana sprzętu lub transportu lub rekonfiguracja
  • Zdarzenia środowiskowe, takie jak awarie zasilania, awarie transportu, awarie dysków
Niewykryte zmiany
  • Uszkodzenie zasobów oprogramowania lub systemów plików
  • Operacje powodujące konflikty w sieci, sieci SAN lub hostach
  • Rekonfiguracja transportu lub hostów przez inne zespoły
  • Zwiększenie ilości danych lub ruchu transportowego
  • Zdarzenia nie katastrofalne w środowisku, które nie zgłaszają alertów
Podczas przygotowywania problemu do rozszerzonego przeglądu i rozwiązywania problemów technicznych należy zwrócić uwagę na poniższe ogólne dyrektywy. Elementy te zapewnią gromadzenie wystarczających danych mechanicznie oraz że zostaną zadane prawidłowe pytania w celu odpowiedniego zakwalifikowania problemu.
 

Cause

Wyraźnie określ problem:
  • Co to jest operacja lub atrybut, który ulega awarii, deviant lub jest przedmiotem pytań? Jakie szczegóły sekwencji błędów są dostępne?
  • Które komponenty i ścieżki danych są związane, np. pliki binarne, sanie / przełączniki sieciowe? Wersje oprogramowania? Typy lub instancje pamięci masowej?
  • GDZIE w normalnym przepływie pracy występuje problem? Czy w przypadku próby wykonania tej samej operacji przy użyciu innego przepływu pracy wyniki są inne?
  • KIEDY wystąpił problem po raz pierwszy? Jak długo trwa? Jakie daty i godziny nastąpiły od tego czasu? Czy ostatnio zidentyfikowano zmiany?
  • W JAKI sposób występuje problem: spójnie lub sporadycznie? W jaki sposób rozwiązano problem po jego wystąpieniu?
  • Kim są hosty uczestniczące w problemie i jakie są ich właściwości (typ hosta NetWorker, wersja NetWorker, nazwa, IP, system operacyjny, procesor itp.)?
  • DLACZEGO niektóre komponenty są zagrożone, gdy podobne komponenty nie są? Jakie są różnice między komponentami, które nie uległy zmianie, ale są podobne?

Resolution

OGÓLNE DZIENNIKI

Większość dzienników NetWorker można zbierać z serwerów Windows i Linux NetWorker, węzłów pamięci masowej i/lub klientów za pomocą narzędzia NSRGET. Narzędzie można pobrać z:

https://central.dell.com/solutions/Networker-Tools


1. Wyodrębnij narzędzie NSRGET do dowolnego katalogu
tymczasowego 2. Instrukcje dotyczące korzystania z narzędzia NSRGET można znaleźć w: NetWorker: Korzystanie z narzędzia do gromadzenia

danych NSRGet NetWorkerNastępujące dzienniki szczegółów bazy wiedzy używane przez NetWorker: NetWorker: Pliki dziennika i lokalizacje


Zbierz następujące elementy ze wszystkich hostów NetWorker (w tym węzłów serwera i pamięci masowej):

  • Pliki debugowania NetWorker: lista katalogów [nsr]/debugowania
    • Ten katalog powinien być pusty. Jeśli w katalogu /nsr/debug znajdują się pliki, które pokrywają się z datą zgłoszenia problemu, może to oznaczać problem.
  • Pliki główne NetWorker: 
    • Linux: /nsr/rdzenie
    • Windows: C:\Program Files\EMC NetWorker\nsr\cores
  • Dzienniki aplikacji NetWorker: zip z [nsr]/apps; zip z [nsr]/applogs; zip z [nsr]/rmagentps/logs; pakiet [nsr]/logs/lib*, nsrbr*, nsrsnap**
  • Dzienniki NetWorker: [nsr]/logs/daemon.raw, [nsr]/logs/networkr.raw
  • Konfiguracja klienta NetWorker: zip z [nsr]/res/nsrladb, [nsr]/res/servers file (może nie istnieć), [nsr]/res/nsrdb (jeśli serwer NetWorker)
    • Są one gromadzone przez narzędzie NSRGET.
  • Skrypt startowy: Solaris & Linux - /etc/init.d/networker, HPUX - /sbin/init.d/networker
  • Dzienniki zasad tworzenia kopii zapasowych: 
    • Linux: /nsr/dzienniki/zasady/POLICY_NAME/WORKFLOW_NAME
    • Windows: C:\Program Files\EMC NetWorker\nsr\logs\policy\POLICY_NAME\WORKFLOW_NAME
  • Wersja i kompilacja NetWorkerNetWorker: Metody identyfikacji wersji oprogramowania NetWorker
  • Znane poprawki zainstalowane dla NetWorker
  • System operacyjny, wersja, poziom poprawek, procesor i szerokość bitów (32/64 bity)
    • Linux: wydanie cat/etc/*; uname -m
    • Windows: systeminfo | findstr "OS Type"
    • NSRGET lub EMCREPORTS zawiera również szczegółowe informacje na temat wersji systemu operacyjnego i architektury systemu.
  • Narzędzie raportów EMC: https://www.dell.com/support/home/en-us/product-support/product/emcreports/drivers
    • Raporty EMC gromadzą dodatkowe informacje o hoście, w tym pełne szczegóły systemu operacyjnego i konfigurację, komunikaty systemu operacyjnego lub dzienniki zdarzeń; Niektóre z tych informacji są również gromadzone w NSRGET; natomiast raporty EMC są bardziej specyficznymi dziennikami operacyjnymi. Raporty EMC mogą być gromadzone w ramach współpracy z NSRGET lub w systemie, w którym może nie być zainstalowane oprogramowanie klienckie NetWorker; na przykład maszynę wirtualną VMware z kopią zapasową vProxy. 
  • Zrzuty rdzenia: NetWorker: Rozwiązywanie problemów z głównymi zrzutami
  • W przypadku podejrzenia problemów z rozpoznawaniem nazw: NetWorker: Najlepsze praktyki rozwiązywania problemów z rozpoznawaniem nazw

Zbierz następujące elementy tylko z serwera NetWorker :
  • Baza danych zasobów NetWorker: Spakowana kopia [nsr]/res/nsrdb
  • Baza danych nośników NetWorker: Eksportowanie bazy danych nośników NetWorker za pomocą pamięci nsrmmdbasm
  • Narzędzie NSRGET zbierze większość wymaganych dzienników; jednak nie będzie zbierać:
    • Dzienniki AUTHC (uwierzytelnianie):
      • Linux: /nsr/dzienniki/authc
      • Windows: C:\Program Files\EMC NetWorker\nsr\authc-server\tomcat\logs
    • Dzienniki konsoli zarządzania NetWorker Management Console (NMC) (gstd):
      • Linux: /opt/lgtonmc/dzienniki/
      • Windows: C:\Program Files\EMC NetWorker\Management\GST\logs
    • Dzienniki sieciowego interfejsu użytkownika NetWorker (NWUI):
      • Linux: /opt/nwui/dzienniki
      • Windows: C:\Program Files\EMC NetWorker\nwui\logs
Zbierz następujące elementy z dowolnego węzła pamięci masowej NetWorker (w tym serwera):
  • Polecenie wykrywania NetWorker: zapytanie -lc output
  • Bus NetWorker bus: Wyjście lusbinfo/lusbinfo -v
  • Dane wyjściowe poleceń NetWorker SJI: sjisn [x.y.z], sjirdtag [x.y.z], sjirjc [x.y.z] (gdzie x.y.z to adres SCSI LUB uchwyt pliku urządzenia)
  • Wyjścia poleceń CDI NetWorker: cdi_inq -f [dev] -v, cdi_get_config -f [dev] -v, cdi_get_status -f [dev] -v, cdi_get_blocksize -f [dev] -v (gdzie dev to device file handle)
  • Podsumowanie urządzeń NetWorker i stanu instalacji: Pamięć nsrmm
  • Proste dane wyjściowe NetWorker autochanger: nsrjb -C [jukebox_name]
  • Szczegóły dysku NetWorker: rekurencyjne katalogi dla każdej struktury AFTD/DD/FTD, a także szczegółowe informacje o urządzeniu dyskowym i metodzie połączenia z hostem.
  • System operacyjny, wersja, poziom poprawek, procesor i szerokość bitów (32/64 bity)
    • Linux: wydanie cat/etc/*; uname -m
    • Windows: systeminfo | findstr "OS Type"
    • NSRGET lub EMCREPORTS zawiera również szczegółowe informacje na temat wersji systemu operacyjnego i architektury systemu.
  • Raporty NSRGET i/lub EMC są zalecane w przypadku zaangażowania w pomoc techniczną.
Uwaga: Powyższe polecenia urządzenia, a także polecenia urządzenia systemu operacyjnego wymienione poniżej mogą powodować resetowanie SCSI, jeśli jest używane na aktywnych urządzeniach. Należy używać tylko wtedy, gdy wszystkie urządzenia taśmowe podłączone do systemu lub określone urządzenia są bezczynne we wszystkich instancjach hosta.

Zbierz następujące elementy z każdego hosta NetWorker License Manager , którego dotyczy problem:
  • Dane wyjściowe polecenia licencjonowania: nsrlic -C
  • Baza danych licencji NetWorker: zip z [nsr]/res/lgtolm.res, [nsr]/res/lictype.res, [nsr]/logs/lgtolmd.log, [nsr]/logs/license*
Zbierz następujące elementy z dowolnego hosta konsoli zarządzania NetWorker Management Console , którego dotyczy problem:
  • System operacyjny, wersja, poziom poprawek, procesor i szerokość bitów (32/64 bity)
    • Linux: wydanie cat/etc/*; uname -m
    • Windows: systeminfo | findstr "OS Type"
    • NSRGET lub EMCREPORTS zawiera również szczegółowe informacje na temat wersji systemu operacyjnego i architektury systemu.
  • Dziennik konsoli zarządzania (gstd.raw — w idealnym przypadku renderowany): 
  • Wersja NMC z numerem kompilacji
  • Wersja Oracle Java JRE: https://www.java.com/en/download/help/version_manual.html Kliknięcie tego hiperłącza powoduje wyświetlenie strony spoza witryny Dell Technologies.  
  • Środowisko pracy NetWorker (NRE):
    • Linux: 
      • rpm -qa | grep nre
      • /opt/nre/java/latest/bin/java -version
    • Windows: 
      • Wersja języka Java będzie wyświetlana w obszarze: C:\Program Files\NRE\java\jre#.#.#_##
        • Jeśli na liście znajduje się wiele folderów Java, sprawdź opcję System Environment Variable JAVA_HOME lub NSR_JAVA_HOME, dla której ścieżki jest obecnie używane przez NetWorker
      • Wersja NRE zostanie wyświetlona w Panelu sterowania w sekcji Programy i funkcje
  • Plik Java Webstart: [nmc]/web/gconsole.jnlp
  • Plik konfiguracyjny NMC: [nmc]/etc/gstd.conf
NetWorker VMware Protection (NVP) vProxy Appliance:

Affected Products

NetWorker

Products

NetWorker Series
Article Properties
Article Number: 000079239
Article Type: Solution
Last Modified: 26 Sept 2023
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.