PowerProtect Data Manager: Storage Array Discover Fails

Summary: PowerProtect Data Manager Storage Array discover fails with ADSD0013: PowerStore discovery cannot be completed because of an internal server error.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Two symptoms are seen:
  • The scheduled or manual discovery job for the storage array fails.
  • The problematic storage array's volume or volume group cannot be shown as the target one while doing restore.
Below error is seen in the discovery log:
discovery-service.log: 2023-10-30T04:48:24.039Z ERROR [] [604c5853-8a26-4c6c-9e6c-3901bcbc0c64-akka.actor.default-dispatcher-5] [][][SUB_TASK_ID:aad2f7aa2ab0f9e9][TRACE_ID:927ed764cfef3843;JOB_ID:811ce7d1084f6791][] [c.e.b.d.a.p.a.PowerStoreApplianceActor.updateDataSourceResouce(317)] - Error during Error parsing response - {} 
com.emc.brs.discovery.adapters.powerStore.util.PowerStoreDiscoveryException: Internal Error: unable to parse json.

Cause

It is a parsing error.
SDMNG discovery model is not having a Fractured ENUM because of which parsing error appears.

Resolution

This issue is addressed in version 19.15.

Affected Products

PowerProtect Software
Article Properties
Article Number: 000219286
Article Type: Solution
Last Modified: 08 Oct 2025
Version:  3
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