NVP-vProxy : Erreurs de connexion continues à partir de vProxy

Summary: NVP-vProxy : Erreurs de connexion continues à partir de vProxy : Impossible de se connecter en raison d’un nom d’utilisateur ou mot de passe incorrect.

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Symptoms

Des erreurs de connexion continues d’un vProxy à un vCenter s’affichent dans le vbackupd.engine.log lorsque le débogage est activé. L’erreur se produit toutes les 5 minutes.
2024-07-18T14:02:54Z INFO: Request #83: Deleted resource: vCenter.com:vm-xxxxxx - xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx. 
2024-07-18T14:02:54Z DEBUG: backupEngine Consumer: establish connection 
2024-07-18T14:02:54Z DEBUG: backupEngine Consumer: get channel 0 
2024-07-18T14:02:54Z TRACE: Request #83: Reply sent successfully for 'DeleteSession'. 
2024-07-18T14:02:54Z TRACE: Purged 0 aged files in '/opt/emc/vproxy/runtime/logs/recycle/daemon'. 
2024-07-18T14:02:56Z ERROR: CleanupMgr: vCenter.com: Scrubber: Unable to log in to vCenter 'vCenter.com': ServerFaultCode: Cannot complete login due to an incorrect user name or password. 
2024-07-18T14:06:18Z DEBUG: Session keepalive on vCenter 'vCenter.com' 
2024-07-18T14:07:52Z DEBUG: CleanupMgr: vCenter.com: Sending 1 requests to scrubber ... 
2024-07-18T14:07:52Z DEBUG: CleanupMgr: vCenter.com: Sent requests to scrubber. 
2024-07-18T14:07:52Z DEBUG: CleanupMgr: vCenter.com: Scrubber: Received 1 requests to scrub. 
2024-07-18T14:07:52Z TRACE: CleanupMgr: vCenter.com: Scrubber: Logging into vCenter 'vCenter.com' 
2024-07-18T14:07:55Z ERROR: CleanupMgr: vCenter.com: Scrubber: Unable to log in to vCenter 'vCenter.com': ServerFaultCode: Cannot complete login due to an incorrect user name or password. 
2024-07-18T14:11:18Z DEBUG: Session keepalive on vCenter 'vCenter.com'

Cause

Les fichiers InventorySessions.gob du vProxy sont utilisés pour stocker les informations de session pour le service nsrvisd du NetWorker Server. L’extension .gob suggère que ces fichiers sont au format Go Binary qui peut contenir des informations de session liées à la gestion de l’inventaire. Dans certains cas, ce fichier peut ne pas avoir été nettoyé et mettre en cache des informations obsolètes sur les informations d’identification de vCenter. Dans certains cas, le fichier InventorySessions.gob peut ne pas être supprimé lors du nettoyage, ce qui entraîne l’échec des tentatives de connexion.

Resolution

La solution de contournement suggérée consiste à renommer le dossier /data01/runtime/state/vbackupd/ ou à supprimer le fichier .gob.

1. Ouvrez une session SSH sur l’appliance vProxy et connectez-vous en tant qu’administrateur.
2. Une fois connecté, passez à l’utilisateur root :
sudo su -
3. Arrêtez le service vbackupd :
systemctl stop vbackupd
4. Renommez le répertoire /data01/runtime/state/vbackupd/ :
mv /data01/runtime/state/vbackupd/ /data01/runtime/state/vbackupd_`date -I`.bak
5. Rechargez les processus vProxy :
systemctl daemon-reload
6. Démarrez vbackupd :
systemctl start vbackupd
Un nouveau répertoire /data01/runtime/state/vbackupd/ est créé.

Additional Information

Assurez-vous que les appliances vProxy déployées sont à jour sur la dernière version majeure prise en charge par le NetWorker Server :
NVP vProxy : Comment mettre à niveau l’appliance NVP vProxy à l’aide de nsrvproxy_mgmt.
Article Properties
Article Number: 000227670
Article Type: Solution
Last Modified: 01 May 2026
Version:  2
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