Avamar: VMware image backup poor performance (RESOLUTION PATH)

Summary: An article to help diagnose slow backup performance of Avamar VMware Image level backups.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

An Avamar Virtual Machine image backup takes a long time to run and times out before the end of the backup window.

Slow-performing image backups cause a bottleneck at the proxy if the pool of image proxies available to service VM clients is insufficient.

This leads to queuing whilst the remaining VM clients wait for a proxy to serve them.

Cause

There are many factors that can cause VM image backups to run slowly or take a long time to complete. See the articles below documenting known issues relating to this type of behavior.

Resolution

Step 1: Gather a full set of 'required' information from the customer.
It is critical to have a detailed understanding of the environment before starting to troubleshoot the situation. Collect the following:

Also, make a note of:

  • The version of vCenter in use
  • The version of the proxy client in use

Step 2: Gather logs for the image backup.

Step 3: Review known issues.
Check the 'troubleshooting' section of the Avamar for VMware User Guide for common issues. Next, check the following;

  • Check if CBT is enabled for the VM.

See the following VMware articles: 

  • Broadcom VMware article 1020128 Changed Block Tracking (CBT) on virtual machines

Step 4: If the issue remains after the above issues have been corrected, escalate to the next level of support.

Additional Information

VM image backups work differently to traditional Avamar backups where the Avamar agent is installed as 'guest' service within the operating system.

During a traditional file system backup, the 'avtar' process scans the dataset and processes any files detected as new or modified. The time taken to complete the backup is proportional to the number of files in the dataset PLUS the combined size of all modified files.

A detailed discussion on this behavior is available in:

With VM image backups, the proxy mounts the client's virtual disks. Avtar processes storage blocks, rather than files

If VMware's "Changed Block Tracking" (CBT) feature is enabled for the VM, only blocks containing changed data is processed. This minimizes data to be processed and reduces resource consumption.  

This drastically improves performance for clients with millions of files, but a low change rate.

For more information see the Avamar for VMware User Guide:

Affected Products

Avamar

Products

Avamar, Avamar Client, Avamar Client for VMware
Article Properties
Article Number: 000041062
Article Type: Solution
Last Modified: 07 Oct 2025
Version:  7
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