Data domain - Detect Duplicate IP Addresses

Summary: This document demonstrates three methods to verify no duplicate IP problems exist.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms



 

Detect Duplicate IP Addresses

PURPOSE

This document describes four methods to detect duplicate IP addresses in a network.

  1. Auto-detect duplicate IP feature, available in DD OS 5.3
  2. User-level CLI command "net troubleshooting duplicate-ip," available in DD OS 5.1
  3. Use command-line based tools comparing the IP and corresponding MAC address
  4. Use ping to verify a duplicate IP problem

APPLY TO

  • All Data Domain systems
  • All Software Releases

Cause

CAUSE

Duplicate IP addresses cause dropped connections.  In a TCP dump, there are many RESET packets due to duplicate IP addresses.

Resolution

     

    SOLUTION

    Method 1:

    DD OS 5.3 introduces a new feature to automatically detect duplicate IP addresses and send an alert.  The feature runs in passive mode (default) or active mode. 

    1. To enable the feature in active mode, set the DD OS registry key as follows.
    To turn on use:

    regset  config.net.dad_active_mode 1
    

    To turn off use:

    regset  config.net.dad_active_mode 0
    

    When running in active mode, configuring a network interface with an IP address can take up to 90 s while the system checks for IP address duplication.   Example output is given below:

    # net config eth0b 10.32.228.83 **** Found duplicate address: ifname=eth0b, ip=10.32.228.83, remote mac=60:EB:69:DC:28:AE; local interface eth0b has been brought down.

    2. To enable the feature in passive mode, the net option can be used.

    • Turn passive check on and send an alert on error: 
      net option set net.dd.dad_alert 1
    • Turn passive check on, but only log errors, without alert:  
      net option set net.dd.dad_alert 2
    • Turn passive check off:
      net option set net.dd.dad_alert 0

    Passive mode checks the Address Resolution Protocol (ARP) activity in the kernel.  If a duplicate IP address is found, the system sends an alert and or log an error based on the feature configuration.  An output example is given below:

    # ping -c 1 -I eth0a 10.32.228.83
    # alerts show current
    
    29 Tue Feb 28 10:55:26 2012 ERROR Network DuplicatedIPAddr=10.32.228.83 Duplicate IP address detected.

    Method 2:

    Use the command, net troubleshooting duplicate-ip.  This command sends out an Address Resolution Protocol (ARP) from every IP address in the Data Domain system and wait for a response.  This method applies to a system with DD OS 5.1 or above.

    1. # net troubleshooting duplicate-ip

       
    2. If no duplicate IP is found, the output is:
    No duplicate IP addresses detected
    
    1. If a duplicate IP is found, an example of the output is like that below:
    Port      IP Address   Details
    -------   ----------   -----------------------------------------------
    eth0:55   10.10.10.1   Duplicate IP from MAC address 00:A0:D1:EC:FE:AD
    -------   ----------   -----------------------------------------------
     
    Method 3:

    Verify the MAC address of the Ethernet interface on the Data Domain system using the Address Resolution Protocol (ARP).

     

    NOTE: This method can only be performed from a system that is on the same subnet as the Data Domain system.

     

    1. Connect and log in to the Data Domain system.
    2. Determine the configured IP address. At the command prompt type:
    # net show settings
    
    Note the IP address.

    Sample output:

    port  enabled  DHCP  IP address        netmask           type     additional setting
    ----  -------  ----  ----------------  ----------------  -------  ------------------
    eth0  yes      yes   192.168.9.65*     255.255.252.0     *        n/a
    ----  -------  ----  ----------------  ----------------  -------  -----------------
    
    
     
    1. Determine the MAC address. At the command prompt type:
    # net show hardware
    
    
     

    Sample output:

    Port  Speed     Duplex   Supp Speeds  Hardware Address   Physical  Link Status
    ----  --------  -------  -----------  -----------------  --------  -----------
    eth0  1000Mb/s  full     10/100/1000  00:15:17:8f:59:64  Copper    yes
    ----  --------  -------  -----------  -----------------  --------  -----------
    Note the MAC address associated with the IP address assigned to the relevant Ethernet interface.

    (In this example the Ethernet interface eth0 has an IP address of 192.168.9.65 and a MAC address of 00:15:17:8f:59:64).

    Use the Address Resolution Protocol (ARP) from Windows to determine if there is a duplicate IP address on the network.

    1. Log on to the Windows media server that is connected to your Data Domain System.
    2. Click Start->Run and type:

    cmd

    Click: OK

    1. At the command prompt type:  
    ARP -a 192.168.9.65

     

    1. Run this command continuously for at least 20 s and each time the output should contain the MAC address 00:15:17:8f:59:64
    2. If the output has any other MAC address, a duplicate IP exists in the network.

    Method 4:

    Using ping to verify a duplicate IP problem:

    This method is more disruptive as it requires disconnecting the Ethernet cable, followed by a simple ping test.

     

    NOTE: Ensure that no backups are occurring on the system and the system is local to your location!

     

    1. Disconnect the Ethernet cable from the Data Domain system.
    2. Log in to the Windows media server that is connected to your Data Domain system.
    3. Click Start->Run and type:

    cmd

    Click: OK

    1. At the command prompt type:
    #ping <ip address of the Data Domain system>

     

    Example:

    ping 192.168.9.65

     

    1. There should not be a ping response as the cable is disconnected. If there is a ping response, this would confirm that the IP address is already in use by another system. The solution is to use a different IP address or contact the network administrator.
    2. Reconnect the Ethernet cable to the Data Domain system.

    Affected Products

    Data Domain, DD OS 5.1, DD OS 5.3
    Article Properties
    Article Number: 000042611
    Article Type: Solution
    Last Modified: 03 Jul 2024
    Version:  5
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