ECS : GeoDrive : erreur lors du téléchargement en plusieurs parties - ECS : 2001 - Accès refusé - Interdit (403)
Summary: Les téléchargements réussis renvoyaient 500 erreurs : les téléchargements multipart renvoyaient « Access Denied » plutôt que « ObjectUnderRetention ». La solution de contournement consiste à augmenter le seuil de MPU afin d’éviter les fichiers MPU plus volumineux. ...
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Symptoms
Si une demande PUT normale est utilisée pour remplacer un objet qui existe déjà et est en rétention, la demande PUT échoue avec cette erreur S3 :
ObjectUnderRetention If a multi-part (MPU) PUT is used to replace an object that is in retention, it receives this error:
AccessDenied The issue here is that a normal PUT and a MPU PUT should return the same error but do not.
Cause
Il est possible qu’un PUT échoue avec une erreur 500. Si cela se produit, l’expéditeur constate qu’il s’agit d’une erreur, même si les fichiers ont été téléchargés avec succès.
Toute erreur indique à GeoDrive que le fichier a échoué et qu’il est mis en file d’attente pour une nouvelle tentative.
Si au cours de la nouvelle tentative, il reçoit « ObjectUnderRetention », GeoDrive comprend que le fichier a été téléchargé et ajuste le fichier local pour le refléter.
Puisque put multipart renvoie « AccessDenied », GeoDrive continue de réessayer le téléchargement.
Toute erreur indique à GeoDrive que le fichier a échoué et qu’il est mis en file d’attente pour une nouvelle tentative.
Si au cours de la nouvelle tentative, il reçoit « ObjectUnderRetention », GeoDrive comprend que le fichier a été téléchargé et ajuste le fichier local pour le refléter.
Puisque put multipart renvoie « AccessDenied », GeoDrive continue de réessayer le téléchargement.
Resolution
1. À partir de la console GeoDrive : vérifiez si l’une des erreurs ci-dessous est générée :
I. Double-cliquez sur un exemple d’erreur MPU pour confirmer la sortie de l’erreur :
I. Double-cliquez sur un exemple d’erreur MPU pour confirmer la sortie de l’erreur :
File cannot be uploaded to ECS server. Retries are exhausted (ECSxxxxx_ECSxxxxx): e:\x\x\... Site=x File=x Line=x Revision=-v2.0.2.2 Severity=WARNING Category=0 Process=Server Error=2149122451:2149122451 - Forbidden (403). Time=22/11/2019 2:36:39 988 ms Thread=15108 Error during multipart upload (e:\xxx) in ECS server ECSxxxxx_ECSxxxxx: 2149122451 - Forbidden (403). ECS: 2001 - Access Denied Http: 403 - Forbidden: The server understood the request, but refuses to fulfill it. S3 Code: AccessDenied S3 Resource: xxx S3 RequestID: xxxxxxxx:xxxxxxxxxxx:xxxxx:xxx ii. Alternative sample console output indicating this issue:
File cannot be uploaded to ECS server. Retries are exhausted (ECSxxxxx_ECSxxxxx): e:\x
Cryptographic Services failed while processing the OnIdentity() call in the System Writer Object.
Error during multipart upload (e:\x) in ECS server ECSxxxxx_ECSxxxxx: 2149122451 - Forbidden (403).
ECS: 2001 - Access Denied
2. Gather and confirm the following system and configuration information to be included the Service Request with ECS Support:
i. Version of GeoDrive being used
ii. Name of the affected ECS bucket and the object user
iii. The affected drive and any error output included in the GeoDrive console
iv. If there were any recent changes made to the system's configuration
v. If the affected files are larger than 128 MB (This is the default size where MPUs are used)
vi. Has this value been changed (Option - Performance: The threshold is at the bottom of the dialog)
3. If all the affected files are 128 MB or larger, please increase the MPU threshold (If not, please notify ECS Support through a Service Request and include all prior and subsequent information)
- This increment can be done through Options, then Performance as below (Of the two fields below, the "Minimum Threshold" is the field to be changed):
- This should cause the larger files to avoid MPU and therefore return the correct error ("ObjectUnderRetention")
- All files should work on retry
- When a file is queued for upload, if it fails it will be queued for a retry. If it tries 3 times and fails each time, it gets put on a "failed upload" list. Each failed upload will log the error - After the 3rd retry, it logs an additional error:
File cannot be uploaded to ECS server. Retries are exhausted (ECSxxxxx_ECSxxxxx): e:\x\x\... - There is a button on the main UI screen that appears if this happens, and the user can press this button to get a list of failed uploads. - If the user ignores it and does not try to force a retry - After 6 hours all failed uploads are put back in the upload queue for 3 more times (All files therefore retry 3 times every 6 hours). 4. If the above does not resolve this issue, please notify ECS Support through a Service Request and include all prior information.
Affected Products
ECS ApplianceProducts
ECS Appliance, ECS Appliance Gen 1, ECS Appliance Gen 2, ECS Appliance Gen 3, ECS Appliance Software with Encryption, ECS Appliance Software without EncryptionArticle Properties
Article Number: 000053659
Article Type: Solution
Last Modified: 17 Feb 2023
Version: 3
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