ECS: GeoDrive - Błąd podczas przesyłania wieloczęściowego — ECS: 2001 - Odmowa dostępu - Zabronione (403)

Summary: Pomyślne przesyłanie zwróciło 500 błędów — przesyłanie wielopartyjne zwróciło komunikat "Odmowa dostępu" zamiast "ObjectUnderRetention". Obejście problemu to zwiększenie progu MPU w celu uniknięcia MPU większych plików. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Jeśli do zastąpienia obiektu, który już istnieje i który jest w stanie zachowania, zwykłe żądanie PUT zostanie użyte do zastąpienia obiektu, który już istnieje, żądanie PUT nie powiedzie się z tym błędem S3:
ObjectUnderRetention
If a multi-part (MPU) PUT is used to replace an object that is in retention, it receives this error:

AccessDenied
 The issue here is that a normal PUT and a MPU PUT should return the same error but do not.

Cause

Możliwe, że błąd PUT może wystąpić z błędem 500. Jeśli tak się stanie, nadawca widzi, że jest to błąd, nawet jeśli pliki zostały przesłane pomyślnie.

Każdy błąd informuje GeoDrive, że plik nie powiódł się i znajduje się w kolejce do ponownej próby.

Jeśli podczas ponawiania próby pojawi się komunikat "ObjectUnderRetention", GeoDrive rozumie, że plik został przesłany i dostosowuje plik lokalny w celu odzwierciedlenia tego.

Ponieważ program PUT wieloczęściowy zwraca wartość "AccessDenied", GeoDrive nadal próbuje ponownie przesłać.

Resolution

1. W konsoli GeoDrive sprawdź, czy jeden z poniższych błędów jest generowany:

     I. Kliknij dwukrotnie przykładowy błąd MPU, aby potwierdzić wynik błędu:
File cannot be uploaded to ECS server. Retries are exhausted (ECSxxxxx_ECSxxxxx): e:\x\x\...
 

  Site=x  File=x  Line=x  Revision=-v2.0.2.2
  Severity=WARNING  Category=0  Process=Server  Error=2149122451:2149122451 - Forbidden (403).
  Time=22/11/2019 2:36:39 988 ms   Thread=15108
Error during multipart upload (e:\xxx) in ECS server ECSxxxxx_ECSxxxxx: 2149122451 - Forbidden (403).
ECS: 2001 - Access Denied
Http: 403 - Forbidden: The server understood the request, but refuses to fulfill it.
S3 Code: AccessDenied
S3 Resource: xxx
S3 RequestID: xxxxxxxx:xxxxxxxxxxx:xxxxx:xxx
     ii. Alternative sample console output indicating this issue:

File cannot be uploaded to ECS server. Retries are exhausted (ECSxxxxx_ECSxxxxx): e:\x

Cryptographic Services failed while processing the OnIdentity() call in the System Writer Object.

Error during multipart upload (e:\x) in ECS server ECSxxxxx_ECSxxxxx: 2149122451 - Forbidden (403).
ECS: 2001 - Access Denied

2. Gather and confirm the following system and configuration information to be included the Service Request with ECS Support: 
     i. Version of GeoDrive being used
     ii. Name of the affected ECS bucket and the object user
     iii. The affected drive and any error output included in the GeoDrive console
     iv. If there were any recent changes made to the system's configuration
     v. If the affected files are larger than 128 MB (This is the default size where MPUs are used)
     vi. Has this value been changed (Option - Performance: The threshold is at the bottom of the dialog)

3. If all the affected files are 128 MB or larger, please increase the MPU threshold (If not, please notify ECS Support through a Service Request and include all prior and subsequent information)
     - This increment can be done through Options, then Performance as below (Of the two fields below, the "Minimum Threshold" is the field to be changed):

kA23a000000GGFvCAO_2_0
     - This should cause the larger files to avoid MPU and therefore return the correct error ("ObjectUnderRetention")
     - All files should work on retry
     - When a file is queued for upload, if it fails it will be queued for a retry. If it tries 3 times and fails each time, it gets put on a "failed upload" list. Each failed upload will log the error - After the 3rd retry, it logs an additional error:
File cannot be uploaded to ECS server. Retries are exhausted (ECSxxxxx_ECSxxxxx): e:\x\x\...

     - There is a button on the main UI screen that appears if this happens, and the user can press this button to get a list of failed uploads.
     - If the user ignores it and does not try to force a retry - After 6 hours all failed uploads are put back in the upload queue for 3 more times (All files therefore retry 3 times every 6 hours).

4. If the above does not resolve this issue, please notify ECS Support through a Service Request and include all prior information.

Affected Products

ECS Appliance

Products

ECS Appliance, ECS Appliance Gen 1, ECS Appliance Gen 2, ECS Appliance Gen 3, ECS Appliance Software with Encryption, ECS Appliance Software without Encryption
Article Properties
Article Number: 000053659
Article Type: Solution
Last Modified: 17 Feb 2023
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.