ECS: Los valores separados por comas en atributos de dominio para el autoservicio de claves S3 no funcionan

Summary: Los valores separados por comas en atributos de dominio para el autoservicio de claves S3 no funcionan.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

El cliente está tratando de simplificar la administración permitiendo que el inicio de sesión (y, en última instancia, la creación de claves de autoservicio de S3) utilice el atributo de AD "sAMAccountName".
Esto se configura en el nivel del espacio de nombres (Administrar > espacio de nombres).

Una vez que se configuran dos valores separados por comas, el autoservicio de claves falla y se muestran errores a continuación.
Si se utilizan por separado (solo un valor configurado), cada uno de ellos funciona.

kA23a000000GCA3CAO_3_0

El primer inicio de sesión es cuando solo hay una entrada (se crea un token):
[user@client ~]$ curl -I -s https://$MANAGEMENT_ENDPOINT/login -u "$MANAGEMENT_USER:$MANAGEMENT_PASSWORD"
HTTP/1.1 200 OK
Date: Fri, 17 May 2019 07:57:29 GMT
Content-Type: application/xml
Content-Length: 0
Connection: keep-alive
X-SDS-AUTH-TOKEN: BAAcbmZXWHBVcVh5U2UrNjY3YkFkNnJuRHV5a2xzPQMAjAQASHVybjpzdG9yYWdlb31YzNkMWYzYzRjMwIADTE1NTgwMzE5NjQyODMDAC51cm
46VG9rZW46Y2MzNTMwMT1M6VmlydHVhbERhdGFDZW50ZXJEYXRhOjFmMTQyOTExLTM4NzktNGI3OC1hYWFkLTItMjA4Mi00OTRiLTlhMWUtOWRkZjBlMDQ2NjIwAgAC0A8=

The second one is when there is a comma separated values (not working, HTTP 500 Error):
[user@client ~]$ curl -I -s https://$MANAGEMENT_ENDPOINT/login -u "$MANAGEMENT_USER:$MANAGEMENT_PASSWORD"
HTTP/1.1 500 Internal Server Error
Date: Fri, 17 May 2019 07:57:49 GMT
Content-Type: text/html;charset=iso-8859-1
Content-Length: 261
Connection: keep-alive
Cache-Control: must-revalidate,no-cache,no-store

Third login is again only one entry, the 2nd one (a Token is created again):
[user@client ~]$ curl -I -s https://$MANAGEMENT_ENDPOINT/login -u "$MANAGEMENT_USER:$MANAGEMENT_PASSWORD"
HTTP/1.1 200 OK
Date: Wed, 22 May 2019 12:25:32 GMT
Content-Type: application/xml
Content-Length: 0
Connection: keep-alive
X-SDS-AUTH-TOKEN: BAAcWXV2QXpjTDVnd016dW9Tc3hWWXd6NUI4elBvPQMAjAQASHVybjpzdG9yYWdlb31YzNkMWYzYzRjMwIADTE1NTg0NjM5NjQzNzEDAC51cm
46VG9rZW46Nzc0NDI1MmUt1M6VmlydHVhbERhdGFDZW50ZXJEYXRhOjFmMTQyOTExLTM4NzktNGI3OC1hYWFkLTIDQyNi00OGRlLWFhMTctNjMzZmNiNzY0NTJhAgAC0A8=

 

Cause

Se descubrió un problema que provocaba que el autoservicio de claves de S3 no funcionara según lo esperado cuando se utilizan valores separados por comas en atributos de dominio.

Resolution

No se conoce la causa raíz del problema y Dell ECS Development está investigando el problema.

Una solución alternativa para mitigar el problema es crear un grupo de Active Directory (AD) en el que se puedan agregar usuarios que utilizan ECS.
Póngase en contacto con su administrador o equipo de AD para crear un grupo de AD que se pueda utilizar y asegurarse de que se agreguen todos los usuarios adecuados.

Para agregar este grupo a ECS:
  1. Elija manage -> namespace -> edit
  2. Si aún no lo ha hecho, haga clic en "Domain". 
  3. Agregue el nombre del grupo al campo Grupos. Dado que no se necesitan atributos, haga clic en la X junto al campo de atributos y se cerrará.
  4. Haga clic en Guardar.

kA23a000000GCA3CAO_2_0

Después de configurar el espacio de nombres de ECS con el grupo, los usuarios se pueden agregar o eliminar a través del grupo de AD sin ningún cambio en ECS.


Additional Information

Suscríbase a las actualizaciones del producto.
Puede suscribirse a las actualizaciones siguiendo las instrucciones que se indican en el siguiente artículo de la base de conocimientos:
DELL: ¿Cómo suscribirse a las páginas de productos: soporte de Dell?

Affected Products

ECS Appliance

Products

ECS Appliance, Elastic Cloud Storage
Article Properties
Article Number: 000056273
Article Type: Solution
Last Modified: 13 Feb 2023
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.