ECS: S3 anahtarlı self servis için etki alanı özniteliklerinde virgülle ayrılmış değerler çalışmıyor

Summary: S3 anahtarlı self servis için etki alanı özniteliklerinde virgülle ayrılmış değerler çalışmıyor.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Müşteri, "sAMAccountName" AD özniteliğini kullanarak oturum açma (ve sonunda S3 self servis anahtarı oluşturma) özelliğine izin vererek yönetimi basitleştirmeye çalışıyor.
Bu, ad alanı düzeyinde yapılandırılmıştır (Ad alanını > yönet).

virgülle ayrılmış iki değer yapılandırıldığında, anahtar self servis aşağıda gösterilen hatalarla başarısız olur.
Ayrı olarak kullanılıyorsa (yalnızca bir değer yapılandırılmışsa), her biri çalışır.

kA23a000000GCA3CAO_3_0

İlk oturum açma, yalnızca bir giriş olduğunda (Bir Belirteç oluşturulur):
[user@client ~]$ curl -I -s https://$MANAGEMENT_ENDPOINT/login -u "$MANAGEMENT_USER:$MANAGEMENT_PASSWORD"
HTTP/1.1 200 OK
Date: Fri, 17 May 2019 07:57:29 GMT
Content-Type: application/xml
Content-Length: 0
Connection: keep-alive
X-SDS-AUTH-TOKEN: BAAcbmZXWHBVcVh5U2UrNjY3YkFkNnJuRHV5a2xzPQMAjAQASHVybjpzdG9yYWdlb31YzNkMWYzYzRjMwIADTE1NTgwMzE5NjQyODMDAC51cm
46VG9rZW46Y2MzNTMwMT1M6VmlydHVhbERhdGFDZW50ZXJEYXRhOjFmMTQyOTExLTM4NzktNGI3OC1hYWFkLTItMjA4Mi00OTRiLTlhMWUtOWRkZjBlMDQ2NjIwAgAC0A8=

The second one is when there is a comma separated values (not working, HTTP 500 Error):
[user@client ~]$ curl -I -s https://$MANAGEMENT_ENDPOINT/login -u "$MANAGEMENT_USER:$MANAGEMENT_PASSWORD"
HTTP/1.1 500 Internal Server Error
Date: Fri, 17 May 2019 07:57:49 GMT
Content-Type: text/html;charset=iso-8859-1
Content-Length: 261
Connection: keep-alive
Cache-Control: must-revalidate,no-cache,no-store

Third login is again only one entry, the 2nd one (a Token is created again):
[user@client ~]$ curl -I -s https://$MANAGEMENT_ENDPOINT/login -u "$MANAGEMENT_USER:$MANAGEMENT_PASSWORD"
HTTP/1.1 200 OK
Date: Wed, 22 May 2019 12:25:32 GMT
Content-Type: application/xml
Content-Length: 0
Connection: keep-alive
X-SDS-AUTH-TOKEN: BAAcWXV2QXpjTDVnd016dW9Tc3hWWXd6NUI4elBvPQMAjAQASHVybjpzdG9yYWdlb31YzNkMWYzYzRjMwIADTE1NTg0NjM5NjQzNzEDAC51cm
46VG9rZW46Nzc0NDI1MmUt1M6VmlydHVhbERhdGFDZW50ZXJEYXRhOjFmMTQyOTExLTM4NzktNGI3OC1hYWFkLTIDQyNi00OGRlLWFhMTctNjMzZmNiNzY0NTJhAgAC0A8=

 

Cause

Etki alanı özniteliklerinde virgülle ayrılmış değerler kullanıldığında S3 anahtarlı self servis işleminin beklendiği gibi çalışmamasına neden olan bir sorun keşfedildi.

Resolution

Sorunun temel nedeni bilinen değildir ve Dell ECS Development tarafından araştırlanmaktadır.

Sorunu azaltmak için geçici çözüm, ECS kullanan kullanıcıların eklenildiği bir Active Directory (AD) grubu oluşturmaktır.
Bilgisayarınızda kullanılan bir AD grubu oluşturmak ve tüm uygun kullanıcıların eklendiklerini sağlamak için AD yöneticinizle veya ekibinizle iletişime geçin.

Bu grubu ECS'ye eklemek için:
  1. Manage - namespace - edit (yönet -> ad alanı - düzenle) öğesini> seçin
  2. Henüz tamam değilseniz "Domain" (Etki Alanı) öğesine tıklayın. 
  3. Grup adını Gruplar alanına ekleyin. Hiçbir öznitelik gerekli olmadığından öznitelikler alanı yanındaki X öğesine tıklayın ve kapanır.
  4. Save (Kaydet) öğesine tıklayın.

kA23a000000GCA3CAO_2_0

ECS ad alanı grupla yapılandırıldıktan sonra, kullanıcılar ECS'de herhangi bir değişiklik yapmadan AD grubu üzerinden eklenebilir veya kaldırılabilir.


Additional Information

Ürün güncelleştirmeleri için abone olun.
Aşağıdaki Knowledge Article'de yer alan talimatları izleyerek güncelleştirmelere abone olabilirsiniz:
DELL: Ürün Sayfalarına abone olma - Dell Destek?

Affected Products

ECS Appliance

Products

ECS Appliance, Elastic Cloud Storage
Article Properties
Article Number: 000056273
Article Type: Solution
Last Modified: 13 Feb 2023
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.