ECS: Beholderen er permanent nede på noden: Symptomkode: 2021
Summary: Denne vidensartikel forklarer, hvorfor ECS har rapporteret, at en beholder er permanent nede på en node.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Systemet har ringet hjem med følgende advarsel:
Clarify Id: APMxxxxxxxx Site Name: UNKNOWN Vendor: EMC DeviceType: ElasticCloudStorageApp Model: ElasticCloudStorage SerialNumber: APMxxxxxxxx WWN: APMxxxxxxxx Platform: platform OS: SLES OS_VER: 12.4 EmbedLevel: 2 InternalMaxSize: 512800 Comment: Fabric Ucode_Ver: 3.7.0.6-7700.ed29023b ConnectType: ESRS IP_Address: Not Available IP_Name: hostname.domainname.net ConnectNum: 169.254.1.1 Port: 22 SymptomCode: 2021 Category: Status Severity: Critical Status: Failed Component: Node ComponentID: xxxxxxx-xxxx-xxxx-xxxx-xxxxxxxx SubComponent: Service SubComponentID: <docker container name> CallHome: true FirstTime: 2023-12-09T07:48:20.232Z Description: Container <container> is permanently down on node <node>
Cause
Beholderen stoppede eller standsede eller startede slet ikke i mindst 10 minutter.
Resolution
Docker-containere (object-main, fabric-lifecycle, fabric-zookeeper, fabric-registry) stoppede eller satte på pause eller startede slet ikke i mindst 10 minutter. Brug følgende fremgangsmåde til at bestemme den fejlbehæftede beholder:
- Baseret på komponent-id eller node-id bestemmes noden i ECS-klyngen, som registrerede fejlen. Eksempel: Komponent-id
4ca42022-46ed-475e-8ab7-6ef9141e5415
sudo /opt/emc/caspian/fabric/cli/bin/fcli lifecycle node.network --id 4ca42022-46ed-475e-8ab7-6ef9141e5415
{
"network": {
"hostname": "hostname.domainname.net", << Hostname
"private_ip": "169.254.1.3", << NAN IP
"mgmt_ip": "10.2.3.4", << Management IP
"public_ip": "10.241.207.59",
"data_ip": "10.241.207.73",
"replication_ip": "10.241.207.59",
"public_interface_name": "public",
"private_interface_name": "private.4",
"mgmt_interface_name": "public",
"data_interface_name": "public:data",
"replication_interface_name": "public"
},
"status": "OK",
"etag": 50
}
- ssh til målnoden ved hjælp af administrations-IP, privat IP eller værtsnavn.
- Kontroller, at dockerserveren fungerer med korrekte parametre
# ps -ef | grep docker root 50062 1 0 Jun02 ? 00:02:11 /usr/bin/docker daemon -H fd:// --insecure-registry=0.0.0.0/0 --log-level=warn
- Dernæst skal vi validere, hvilken container (NAMES Column) der blev stoppet eller slet ikke startet af en eller anden grund (se på kolonnen STATUS):
# sudo docker ps -a CONTAINER ID IMAGE COMMAND CREATED STATUS PORTS NAMES 7bf16df0ef15 464b97154c24 "/opt/vipr/boot/boot." 3 days ago Up 3 days object-main 0ef5cc422543 24d9d6008893 "./boot.sh lifecycle" 3 days ago Up 3 days fabric-lifecycle 87d6c77d98ca 32cce433c3dc "./boot.sh 3 1=169.25" 3 days ago Up 3 days fabric-zookeeper
- Kontrollér, at strukturtjenesten kører. Strukturagent forsøger automatisk at genoplive problembeholderen
# sudo service fabric-agent status fabric-agent.service - fabric agent Loaded: loaded (/usr/lib/systemd/system/fabric-agent.service; enabled) Active: active (running) since Thu 2016-06-02 17:56:39 UTC; 3 days ago Process: 50643 ExecStartPre=/bin/rm -f /var/run/fabric-agent.pid (code=exited, status=0/SUCCESS) Main PID: 50645 (java) CGroup: /system.slice/fabric-agent.service
- Få vist status for stoppet/mislykket beholder
# sudo docker inspect fabric-zookeeper | grep -A12 State
"State": {
"Status": "running",
"Running": true,
"Paused": false,
"Restarting": false,
"OOMKilled": false,
"Dead": false,
"Pid": 80462,
"ExitCode": 0,
"Error": "",
"StartedAt": "2016-06-06T17:29:12.968133861Z",
"FinishedAt": "2016-06-06T17:29:12.882812946Z"
},
Hvis vi stadig er usikre på, om der er et problem eller ej, skal du kontakte ECS tekniske support for at få yderligere hjælp.
Affected Products
ECS Appliance Software without EncryptionProducts
ECS Appliance, ECS Appliance Software with Encryption, ECS Appliance Software without EncryptionArticle Properties
Article Number: 000064491
Article Type: Solution
Last Modified: 17 Dec 2025
Version: 6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.