SourceOne: After moving the SourceOne SQL databases to a new SQL server users cannot modify permissions of mapped folders

Summary: After moving the SourceOne SQL databases to a new SQL server users cannot modify permissions of mapped folders.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms



After moving the EMC SourceOne SQL databases to a new SQL server users cannot modify permissions of mapped folders. Adding users to the mapped folder, or changing permissions may fail to apply. No error is displayed. If the dialog is closed and re-opened, the permissions have not been applied. In some cases the MMC may display an Invalid pointer error:

Invalid pointer  (0x80004003) [ExMMCAdmin.dll, CoExFolderMgr.cpp(916).CCoExFolderMgr::AddPrincipleToList] 
>System call failed. (0x86040100) [ExMMCAdmin.dll, CoExFolderMgr.cpp(460).CCoExFolderMgr::SaveFolder] 
>Invalid pointer  (0x80004003) [ExMMCAdmin.dll, CoExFolderMgr.cpp(916).CCoExFolderMgr::AddPrincipleToList] 
>System call failed. (0x86040100) Unknown error (0x8004C350) [ExMMCAdmin.dll, CoExJDFDB.cpp(868).CoExJDFDB::ExecuteCmd] 

Stack Trace: 
   at EMC.Interop.ExProviderGW.CoExJanusFolderClass.Save()
   at EMC.EX.MMCAdmin.JDFForms.ExFolderMgrPropertySheet.SaveChanges(Boolean& bOKToClose)
   Message      : ExCreateDataSrcCacheApp @AppID=<#>,@AppRowID=<#>,@DataSourceID=<#>,@ExpansionMask=<#>
     : <ServerName> 
Message      : System call failed. (0x86040100) Unknown error (0x8004C350) {Error 60006, severity 11, state 1 was raised, but no message with that error number was found in sys.messages. If error is larger than 50000, make sure the user-defined message is added using sp_addmessage. Error#:18054 Proc:ExCreateDataSrcCacheApp Line:62 Native error: 50000 SQL State: 42000 } 
JobId        : -1
ActivityId   : -1
ActivityType : -1



The ExMMCAdmin.dll.log may record the following error after each failed attempt:

Module       : CoExJDFDB.cpp
Func         : CoExJDFDB::CreateDataSrcCacheApp(6130)
Message      : System call failed. (0x86040100) Unknown error (0x8004C350) {Error 60006, severity 11, state 1 was raised, but no message with that error number was found in sys.messages. If error is larger than 50000, make sure the user-defined message is added using sp_addmessage. Error#:18054 Proc:ExCreateDataSrcCacheApp Line:62 Native error: 50000 SQL State: 42000 } 

 

Cause

During installation the Master database is updated with two sys.messages entries specific to the operation of SourceOne. If the SQL databases are moved to another server, these messages may not be present in the sys.messages table of the new SQL server's Master database.

Resolution

Validate that the SQL server's Master database does not contain sys.messages entries for message_Id values 60006 and 60007.  The following queries can check for these entries: 

Use master 
Select * from sys.messages Where message_id = 60007
Select * from sys.messages Where message_id = 60006


If the entries do not exist in sys.messages. run the following SQL to create them (highlight all rows and run): 

IF NOT EXISTS(SELECT * FROM sys.messages WHERE message_id = 60006 and language_id = 1033)
exec sp_addmessage 60006,11,N'Duplicate object (%s)', N'us_english'--,@replace = 'replace';
GO
IF NOT EXISTS(SELECT * FROM sys.messages WHERE message_id = 60006)
exec sp_addmessage 60006,11,N'Duplicate object (%s)'--,@replace = 'replace';
GO
IF NOT EXISTS(SELECT * FROM sys.messages WHERE message_id = 60007 and language_id = 1033)
exec sp_addmessage 60007,11,N'Data modification check failed. Table(s):%s', N'us_english'--,@replace = 'replace';
GO
IF NOT EXISTS(SELECT * FROM sys.messages WHERE message_id = 60007)
exec sp_addmessage 60007,11,N'Data modification check failed. Table(s):%s'--,@replace = 'replace';
GO


After these changes have been implemented validate that the MMC can now modify permissions on mapped folders. 
 

Affected Products

SourceOne Email Management

Products

SourceOne Email Management
Article Properties
Article Number: 000065471
Article Type: Solution
Last Modified: 27 Jun 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.