Dell G5 (5505) Performance Issues During Intense GPU Usage

Summary: Details on how to fix abnormal behavior, such as Reboot, Shut Down, Abnormal Display Color, Hanging, Blue, or Black Screen Issues during intense GPU usage for the Dell G5 5505.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Symptom

The Dell G5 5505 may encounter multiple abnormal issues during intense GPU usage.

The abnormal symptoms include:

  • Blue Screen
  • Black Screen or Video Loss
  • Auto Reboot
  • Random Shut Down
  • Abnormal Display Color
  • Lag or Hanging Performance

Cause

This can be caused by high/intense GPU usage.

Resolution

To fix this behavior, you must update the system BIOS, Bluetooth, and graphics drivers from the Dell website, along with the AMD Firmware Update Utility (most current version available for all)

  1. Browse to the Dell G5 5505 Drivers site .
  2. Download the BIOS, the Killer Wireless Bluetooth, AMD graphics drivers and AMD Navi 10 Firmware Update Utility.
     
  3. Install the BIOS.
    SLN322205_en_US__1icon Note: Do not power off the system during the BIOS upgrading process.
  4. Install the Killer Wireless AX1650 UWD Bluetooth driver.
     
  5. Install the AMD graphics driver.
  6. Install the AMD Radeon RX 5600M Firmware Update Utility.
 

After the BIOS and drivers are installed, test the system to see if the abnormal issues continue.

If you continue to have issues, contact Dell Technical Support.

Affected Products

Dell G5 SE 5505
Article Properties
Article Number: 000123145
Article Type: Solution
Last Modified: 22 Apr 2025
Version:  6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.