Dell Encryption saattaa lakata vastaamasta, kun aktivoituja käyttäjiä on paljon
Summary: Dell Encryption (aiemmin Dell Data Protection | Encryption) saattaa lakata vastaamasta, kun suuri määrä käyttäjiä aktivoidaan yhdellä laitteella. Tämä vastaamattomuus voi aiheuttaa laitteen käyttöjärjestelmävirheen (sinisen virhenäytön). ...
Symptoms
Tuotteet, joita asia koskee:
- Dell Encryption Enterprise
- Dell Encryption Personal
- Dell Data Protection | Encryption
- Dell Data Protection | Personal Edition
Versiot, joita asia koskee:
- 8.9.0 ja aiemmat
Cause
Dell Encryption tallentaa credsys.vlt-tiedostoon (jota kutsutaan yleisesti varastotiedostoksi) aktivoidut käyttäjätiedot, jotka tallennetaan C:\Windows\system32\. Tiedosto on rajatun kokoinen tiedostopohjainen tietokanta, johon tallennetaan tietoja aktivoidusta käyttäjästä, laitteen salausavaimista, aktivoitujen käyttäjien käytännöistä sekä sidokset avainten ja laitteen käyttäjien välillä. Kun laitteeseen on aktivoitu monia käyttäjiä, tiedoston koko saattaa ylittää tiedostopohjaisen tietokannan kokorajoituksen ja tiedosto saattaa vioittua. Tämä vioittuminen voi ilmetä virheenä CMGShield -tiedostoon, ja koska tämä palvelu on määritetty kriittiseksi palveluksi, käyttöjärjestelmän vika voi ilmetä, jos tämä palvelu epäonnistuu.
Ongelma näkyy CMGShield.log tiedostossa, joka on oletusarvoisesti tallennettu seuraavan ProgramData-hakemistoon: C:\ProgramData\Dell\Dell Data Protection\Encryption\. Jos virheitä esiintyy, tämä tarkoittaa, että varasto ylittää enimmäiskokonsa (tiedot yleistetty, koska ne voivat vaihdella kentässä):
Vault Error - Cluster index <NUMBER> exceeds maximum clusters (<NUMBER>) while validating (<NUMBER>) <POLICYFILENAME> Size=<NUMBER>
Resolution
Järjestelmänvalvojat, joilla tämä ongelma ilmenee, voivat suorittaa WSDeactivate ratkaistaksesi päätepisteen, joka joutuu tähän tilaan. WSDeactivate voidaan hankkia Dell-tuelta tarvittaessa, koska tätä sovellusta ei julkaista ulkoisesti, koska se johtaa tietojen menetykseen, jos laite ei saa yhteyttä palvelimeen.
WSDeactivate voidaan käyttää salatun tietokoneen vianmääritykseen. Apuohjelma nimeää varastotiedoston (credsys.vlt) uudelleen ja lisää päivämäärän ja aikaleiman tiedostonimen loppuun uudelleenkäynnistyskehotteen jälkeen. Tämä prosessi edellyttää, että kaikki aiemmin aktivoidut käyttäjät aktivoidaan uudelleen tähän laitteeseen seuraavalla kirjautumisella.
Ongelma on korjattu Dell Encryption 8.9.1 -versioon ja uudempiin. Ongelma on korjattu määrittämällä aktivoitujen käyttäjien enimmäismääräksi oletusarvoisesti 25 sekä muuttamalla aktivointitietojen koon ja tarkistussummien laskemista säilössä. Kun 26. käyttäjä aktivoidaan, säilöstä poistetaan käyttäjä, joka ei ole kirjautunut pisimpään aikaan.
Arvoa voi muuttaa tarvittaessa muuttamalla rekisteriavainta:
- Varmuuskopioi rekisteri ennen jatkamista, katso Kuinka varmuuskopioida ja palauttaa rekisteri Windowsissa
.
- Rekisterin muokkaamisen jälkeen tietokone voi lakata vastaamasta seuraavan uudelleenkäynnistyksen yhteydessä.
- Ota yhteyttä Dell Data Securityn kansainvälisiin tukipuhelinnumeroihin , jos sinulla on tämän vaiheen suorittamiseen liittyviä huolenaiheita.
HKEY_LOCAL_MACHINE\SOFTWARE\Dell\Dell Data Protection\Encryption DWORD: MaxActivatedUsers Value: <IntegerHere>
Määritetty arvo voi olla vähintään viisi käyttäjää ja enintään 50.
Jos haluat ottaa yhteyttä tukeen, katso luettelo Dell Data Securityn kansainvälisen tuen puhelinnumeroista.
TechDirectissä voit luoda teknisen tukipyynnön verkossa.
Lisätietoja ja resursseja on Dell Security Community Forum -keskustelufoorumilla.