Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products
  • Manage your Dell EMC sites, products, and product-level contacts using Company Administration.

How to Run a Power Supply Unit Self Test On a Dell Desktop or All-in-One Computer

Summary: Learn how to run a self-test diagnostics on the power supply unit of a Dell desktop or all-in-one computer. Built-in Self Test (BIST) helps determine if the power supply unit isSee more

This article may have been automatically translated. If you have any feedback regarding its quality, please let us know using the form at the bottom of this page.

Article Content


Symptoms

What is the Power Supply Unit (PSU) built-in self test (BIST)?

Dell Inspiron, XPS, OptiPlex, Precision and Vostro desktop systems include a power supply with a built in self-test (BIST) feature that helps diagnose the health of the power supply unit. The LED indicator on the PSU helps identify if the power issue is caused by the power supply unit.

SLN308658_en_US__1icon Note: Certain older models of Dell Inspiron, XPS, and Vostro desktop systems may not be equipped with a PSU built-in self test. To troubleshoot power issues, see the Dell knowledge base article How to Troubleshoot Power Issue on a Dell Desktop or All-in-One

Cause

No Cause Associated.

Resolution

How to identify if my Dell desktop computer has the PSU BIST?

The PSU BIST is found on the back panel of the desktop computer, next to the power cable connector (on some smaller chassis types, you may need to remove the system cover to see the BIST on the side of the PSU).

PSU BIST with a test button SLN308658_en_US__2Old_BIST_1
SLN308658_en_US__3Old_BIST_2
SLN308658_en_US__4Old_BIST_3
SLN308658_en_US__5Old_BIST_4
PSU BIST without a test button SLN308658_en_US__6New_BIST_1

How to use the BIST to diagnose power supply issues?

How to run self-test using the button on the PSU

  1. Turn off the system.
  2. Press the BIST button on the system and check whether the LED lights up.
  3. The light should be solid on not flickering or flashing and the power supply fan should also turn on to speed. If the fan is not spinning up properly this should be considered a BIST failure even if the LED lights up.
  • If the BIST LED lights up, then the power supply can deliver power to the system but something else is impeding the POST process. The next step is to check whether the power button might be at fault. If it is not, you should go to the following article for No POST troubleshooting.
  • If the BIST LED does not light up or the PSU fan does not spin correctly, then the power supply can not deliver power to the system and could be caused by any component connected to the power supply or the power supply itself. The next step would be to isolate the source of the power failure by disconnecting parts from the PSU, you should go to the following article for No Power troubleshooting.

How to run self-test without the button on the PSU

  1. Turn off the system.
  2. Disconnect the power cord from the PSU, and wait for 15 seconds.
  3. After 15 seconds, connect the power cord back to the PSU.
  4. The LED light should stay on for 3 seconds and then turn off.
  • If the BIST LED lights up, then the power supply can deliver power to the system but something else is impeding the POST process. The next step is to check whether the power button might be at fault. If it's not you should go to the following article for No POST troubleshooting.
  • If the BIST LED does not light up, then the power supply can't deliver power to the system and could be caused by any component connected to the power supply or the power supply itself. The next step would be to isolate the source of the power failure by disconnecting parts from the PSU, you should go to the following article for No Power troubleshooting.

Article Properties


Affected Product

Desktops & All-in-Ones, Fixed Workstations

Last Published Date

20 Sep 2021

Version

6

Article Type

Solution